1

Topic: [SOLVED] Alias don't work

I install iRedMail 0.7.3 with OpenLDAP backend on CentOs 6

After that I create some user in iRedAdmin, and mailAlias with phpLDAPAdmin as described in Wiki

http://www.iredmail.org/wiki/index.php? … pLDAPadmin

When send mail to alias@domain.com from Roundcubemail I got the following error in /var/log/maillog

Oct 18 23:01:30 mail postfix/smtpd[5963]: NOQUEUE: reject: RCPT from mail.domain.com [127.0.0.1]: 550 5.1.1 <alias@domain.com>: Recipient address rejected: User unknown  in virtual mailbox table

I didn't change anything in configuration after install.

Thanks for any help!

2

Re: [SOLVED] Alias don't work

Could you please paste LDIF data of this alias account (alias@domain.com) here to help troubleshoot?

3

Re: [SOLVED] Alias don't work

ZhangHuangbin wrote:

Could you please paste LDIF data of this alias account (alias@domain.com) here to help troubleshoot?

dn: mail=alias@domain.com,ou=Aliases,domainName=domain.com,o=domains,dc=domain,dc=com
accountstatus: enabled
cn: Alias
description: Test Alias
enabledservice: mail
enabledservice: deliver
enabledservice: displayedInGlobalAddressBook
mail: alias@domain.com
mailforwardingaddress: user1@domain.com
mailforwardingaddress: user2@domain.com
objectclass: mailAlias
objectclass: top

4

Re: [SOLVED] Alias don't work

gotanbl wrote:

accountstatus: enabled

It must be 'active', not 'enabled'. Please fix it and try again. smile

5

Re: [SOLVED] Alias don't work

ZhangHuangbin wrote:
gotanbl wrote:

accountstatus: enabled

It must be 'active', not 'enabled'. Please fix it and try again. smile

Now, it works. My mistake, I did not follow instructions well!

Many thanks ZhangHuangbin!