1

Topic: Can't get SMTP working plain (non SSL/TLS)

==== Required information ====
- iRedMail version: 0.3.3
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): MySQL
- Linux/BSD distribution name and version: Centos 6.5
- Related log if you're reporting an issue:

Jun 16 11:14:53 clandesmail postfix/smtpd[8297]: connect from unknown[186.23.148.13]
Jun 16 11:14:53 clandesmail postfix/smtpd[8297]: lost connection after EHLO from unknown[186.23.148.13]
Jun 16 11:14:53 clandesmail postfix/smtpd[8297]: disconnect from unknown[186.23.148.13]

====

Hello!

I'm trying to get SMTP accepting plain auth, but no success.

I set  "smtpd_tls_auth_only = no"  in  postfix main.cf
Also  "disable_plaintext_auth=no" and "ssl=yes"  in dovecot.conf

Any help will be truly appreciated.

Thank you so much,
Jorge.

2

Re: Can't get SMTP working plain (non SSL/TLS)

What's your SMTP setting in mail client?

3

Re: Can't get SMTP working plain (non SSL/TLS)

Hello!

Setting client for using SSL run OK.

But the customer needs not to use SSL for sending mails, and setting up port 25 (or 587) in plain mode with no SSL gets the client constantly ask for the password.

Thank you.

4

Re: Can't get SMTP working plain (non SSL/TLS)

comintech wrote:

But the customer needs not to use SSL for sending mails, and setting up port 25 (or 587) in plain mode with no SSL gets the client constantly ask for the password.

Why not use SSL/TLS for better security?
If you have to use port 25, just comment out 'smtpd_tls_auth_only =' in Postfix config file /etc/postfix/main.cf.