1

Topic: Relay without verifying local recipients not working

==== Required information ====
- iRedMail version: 1.8.1
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): MySQL
- Linux/BSD distribution name and version:  Debian 7.5
- Related log if you're reporting an issue:
====

If i enable Relay without verifying local recipients on a domain, the flag is not set on this option but after safing i see that this domain is then a backup MX domain and this is not what i like to do.

2

Re: Relay without verifying local recipients not working

gaxy wrote:

If i enable Relay without verifying local recipients on a domain, the flag is not set on this option but after safing i see that this domain is then a backup MX domain and this is not what i like to do.

Is the "backup mx" checkbox grey (not checkable)? And there's a tip icon beside "backup mx" checkbox?

3

Re: Relay without verifying local recipients not working

no, if it is clickable.

what i do is:
go to the domain, click to the "enable Relay without verifying local recipients on a domain" checkbox and save.

if i then go again to this domain i see thet the "enable Relay without verifying local recipients on a domain" checbox is not marked, so could click it again... .when i go wan page back i see then tat the "backupmx box is checked".

i can then disable the backupmx box again but this means that the value of the "enable Relay without verifying local recipients on a domain" checkbox must be wrong som how...

GaXy

4

Re: Relay without verifying local recipients not working

This is a bug in iRedAdmin-Pro-MySQL-1.8.1, the newly released 1.8.2 fixes it. Please follow our upgrade tutorial to upgrade iRedAdmin-Pro-MySQL:
http://www.iredmail.org/wiki/index.php? … .8.1-1.8.2

5

Re: Relay without verifying local recipients not working

now i can click on the  "enable Relay without verifying local recipients on a domain" checkbox and save but nothing happen.

after checking, the checkbox is still not marked anymore...

6

Re: Relay without verifying local recipients not working

Did you set a valid/proper relay or still use 'dovecot' as relay? If you're using 'dovecot', it's a local transport, not a relay. Please use a proper relay like 'smtp:xxx:25' instead, it's described in the right side.

7

Re: Relay without verifying local recipients not working

hmmm i would say that this is not what i like to do or how i understand it:

i am under the domain settings-->relay

Relay/Transport Setting : here i have dovecot, ok

Description on the right:
Received emails will be relayed to specified server.
Per-user relay setting will override per-domain relay setting you set in this page.

but there is also a checkbox:
Relay without verifying local recipients

and if i click to that box, it is never saved.

8

Re: Relay without verifying local recipients not working

i see now what you mean, i was thinking that i can use this checkbax to have a acound on this domain .. a relay@doman.abc
and i can use this relay user then to send mails as Someotheruser@somedomain.zxy

i change the settings in main.cf so that i can do that but with that setting on, all can fake ther mailaddess easy.

9

Re: Relay without verifying local recipients not working

I don't quite understand what you really want/expect.

If you want to perform smtp authentication as 'relay@domain.abc', but make the email looks like sent by 'some_other_user@', you can simply remove 'reject_sender_login_mismatch' in Postfix, then update setting in your mail client application to achieve this.

If this is what you want, then 'relay' is not what you're looking for.

10

Re: Relay without verifying local recipients not working

yes this was the thing that i have done allready.
i was just thinking i can use this to allow it only on a domain and not globaly.

this is done for me now.
thank you for your help.