Topic: How to disable SMTP security in postfix?

==== Required information ====
- iRedMail version: 0.8.6
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): LDAP
- Linux/BSD distribution name and version: Deb7
- Related log if you're reporting an issue:

Hi Zhang,

I'm trying to attach help desk ticket system to iRedMail. Problem is, help desk system relays email to operators - and it changes the 'from' header in the message - and then Postfix rejects it.

How can I allow this behavior? I need turn off SMTP authentication? Or I can tell postfix to let one user send mail from any account -> e.g. my.iredmail.com STMP can send e-mails from 'something@gmail.com' even though it doesn't really come from GMAIL (but my server).

Any advice?


Re: How to disable SMTP security in postfix?

You can try to remove 'reject_sender_login_mismatch' in Postfix main.cf, then reload Postfix service.


3 (edited by sam-the-man 2014-01-20 10:35:30)

Re: How to disable SMTP security in postfix?

Thanks Zhang, Is nice suggestion. Now, the errors go away. The message is sent ok. See below:

But the problem is, I never get the e-mail at dest@address.

Jan 19 21:19:03 node postfix/qmgr[23354]: 7747913758: from=<spoof@address>, size=1329, nrcpt=1 (queue active)
Jan 19 21:19:03 node amavis[32742]: (32742-11) Passed CLEAN {RelayedInternal}, LOCAL []:39820 [] <spoof@address> -> <dest@address>, Queue-ID: 15D2113724, Message-ID: <cerberusweb.contexts.ticket_31_1390184342_cec48dd8@cerb>, mail_id: r3-JdHP1OoWt, Hits: -8.688, size: 849, queued_as: 7747913758, 364 ms
Jan 19 21:19:03 node postfix/smtp[23357]: 15D2113724: to=<dest@address>, relay=[]:10024, delay=1.5, delays=1.1/0/0/0.38, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[]:10025): 250 2.0.0 Ok: queued as 7747913758)

In this example above, the e-mail from is 'spoof@address' and the destination e-mail address is dest@address. the reply-to is not listed.

Doest SpamAssassin block or something because modified headers? It's so close to working this is very strange. Thank you.


Re: How to disable SMTP security in postfix?

Amavisd re-injected email to Postfix queue, looks everything is just fine.
Could you please paste FULL log of this email in Postfix log file? Not just the lines you think should be enough for troubleshooting.