1

Topic: Can't install iRedMail on Centos 6.2

==== Required information ====
- iRedMail version:
- Store mail accounts in which backend (LDAP/MySQL/PGSQL):
- Linux/BSD distribution name and version:
- Related log if you're reporting an issue:
====

Hi. I'm trying to install the latest version of iRedMail with MySql on a centos 6.2 server but the installation fails. The error message I get is below. Thanks in advance for your help.

Error: Package: 1:python-sqlite2-2.3.3-1.el5.x86_64 (epel)
           Requires: python(abi) = 2.4
           Installed: python-2.6.6-37.el6_4.x86_64 (@updates)
               python(abi) = 2.6
           Available: python-2.6.6-36.el6.i686 (base)
               python(abi) = 2.6
           Available: python26-2.6.8-2.el5.x86_64 (epel)
               python(abi) = 2.6
Error: Package: perl-Mail-DKIM-0.39-1.el5.noarch (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)
Error: Package: python-babel-0.9.5-2.el5.noarch (epel)
           Requires: python(abi) = 2.4
           Installed: python-2.6.6-37.el6_4.x86_64 (@updates)
               python(abi) = 2.6
           Available: python-2.6.6-36.el6.i686 (base)
               python(abi) = 2.6
           Available: python26-2.6.8-2.el5.x86_64 (epel)
               python(abi) = 2.6
Error: Package: 2:perl-Convert-UUlib-1.4-1.el5.x86_64 (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)

2

Re: Can't install iRedMail on Centos 6.2

Please upgrade your CentOS 6.2 to the latest 6.4 first.

3

Re: Can't install iRedMail on Centos 6.2

ZhangHuangbin wrote:

Please upgrade your CentOS 6.2 to the latest 6.4 first.

Thank you. I updated the system but I still get the same error message.

4

Re: Can't install iRedMail on Centos 6.2

easystreet wrote:

           Available: python26-2.6.8-2.el5.x86_64 (epel)
               python(abi) = 2.6
Error: Package: perl-Mail-DKIM-0.39-1.el5.noarch (epel)
Error: Package: 1:python-sqlite2-2.3.3-1.el5.x86_64 (epel)

*) Why it try to access EPEL repo for CentOS 5, not for CentOS 6?
*) Did you add EPEL repo file under /etc/yum.repos.d/ manually?
*) Please show us file content of /etc/yum.repos.d/epel.repo.