1

Topic: iRedMail-0.8.5 has been released

Dear all,

iRedMail-0.8.5 has been released. This is a bug fix release.

You cannot install iRedMail-0.8.5 on below Linux/BSD distribution releases
  • Ubuntu 12.10. Please use 12.04 (LTS) or 13.04 instead.

  • RHEL/CentOS 5. Please use RHEL/CentOS 6 instead. RHEL 5 is in End of Production life cycle, we have to drop support for it to reduce our workload and bring you better support for RHEL/CentOS 6: https://access.redhat.com/support/polic … es/errata/

  • OpenBSD 5.1, 5.2. Please use OpenBSD-5.3 instead.

  • openSUSE 12.1, 12.2. Please use openSUSE-12.3 instead.

NOTES:

  • Drop support means you cannot install new iRedMail server on them, but we will continue supporting iRedMail servers which still running on RHEL/CentOS 5.

  • We will drop support for Debian 6 (squeeze) in next iRedMail release, and we recommend all Debian users choose the latest stable release Debian 7 (wheezy) for iRedMail. According to Debian web site: Debian 6 is the current old stable release, "The (Debian) security team tries to support a stable distribution for about one year after the next stable distribution has been released, except when another stable distribution is released within this year. It is not possible to support three distributions; supporting two simultaneously is already difficult enough."

  • We will drop support for Gentoo Linux in next iRedMail release, because just few users are running Gentoo Linux for iRedMail.

  • Maybe you will say why not drop support for OpenBSD, it has just few users too. but it's my favourite Unix distribution, i will continue supporting it.

Improvements
  • Use EPEL yum repo on RHEL/CentOS 6 by default. Details about EPEL repo: http://fedoraproject.org/wiki/EPEL

  • Add SQL trigger to insert value for column 'used_quota.domain' automatically, so that we can easily calculate per-domain used mailbox quota.

  • Able to assign mail alias as member of another mailing alias on MySQL/PostgreSQL backends. NOTE: This is implemented in OpenLDAP backend.

  • New SQL column and LDAP attribute for mail domain, used to store default preferred language for newly created mail users.

It also fixes some issues:
  • Incorrect Amavisd column name: policy.unchecked_lovers_maps (incorrect) -> policy.unchecked_lover.

  • Incorrect LDAP ACL for attribute "memberOfGroup". Thanks Hoang Tuan Viet <vietht _at_ vccloud.vn> for the report.

Package update:
  • Roundcube webmail -> 0.9.2

  • phpMyAdmin -> 4.0.4

  • iRedAdmin -> 0.2.2

  • iRedAPD -> 1.4.1

  • phpPgAdmin -> 5.1

Most used Linux/BSD distributions by iRedMail users since March 26 2013, for iRedMail-0.8.4

Amount  Distribution and release number
4959    CentOS 6
3918    Ubuntu 12.04 (precise)
2539    Debian 6 (squeeze)
1617    Debian 7 (wheezy)
1049    UBUNTU 12.10 (quantal)
1013    CentOS 5
593    UBUNTU 13.04 (raring)
424    FreeBSDD 9   
236    Red Hat Enterprise Linux 6
232    openSUSE 12.3 (dartmouth)
155    Red Hat Enterprise Linux 5
88    OpenBSD 5.3
77    GENTOO
57    Scientific Linux 6
35    OpenBSD 5.2

2 (edited by hata_ph 2013-07-23 13:26:53)

Re: iRedMail-0.8.5 has been released

I try to upgrade phpmyadmin from phpMyAdmin-3.5.5 to phpMyAdmin-4.0.4.1 but it just show me a blank screen when accessing https://xxx.xxx.xxx.xxx/phpmyadmin
If I point /var/www/phpmyadmin back to phpMyAdmin-3.5.5 and it work...any idea?
I am using centos 6.4 with iredmail-0.8.5 ldap backend

btw, no error under /var/log/httpd/error_log

3

Re: iRedMail-0.8.5 has been released

Check Apache log file please.
phpMyAdmin-4.0.4.1 requires php module mbstring, i guess you don't have it installed. The package name should be php-mbstring.

4

Re: iRedMail-0.8.5 has been released

Thanks. Installing php-mbstring do the trick. smile

5

Re: iRedMail-0.8.5 has been released

I only have a Centos 5.9 system available at this time.
Install script for iRedMail-0.8.5 correctly  says unsupported.

If I try to install iRedMail-0.8.4 the install script says

Your iRedMail version (0.8.4) is out of date, please
< ERROR > download the latest version and try again

Can you offer any suggestions on how get 0.8.4 or last version of iRedMail for Centos 5.9?

I already have Centos 5.8 system running RedMail-0.8.3 in production.
Need to migrate production to new server.

6

Re: iRedMail-0.8.5 has been released

Hi ckwong,

You can comment out below line in iRedMail-0.8.5/pkgs/get_all.sh to let it not to check new version:

# Check latest version                                                             
check_status_before_run check_new_iredmail

Again, it's recommend to always use the latest iRedMail release. is it that hard to get a CentOS 6 instead of your 5.9?

7

Re: iRedMail-0.8.5 has been released

ZhangHuangbin wrote:

Hi ckwong,

You can comment out below line in iRedMail-0.8.5/pkgs/get_all.sh to let it not to check new version:

# Check latest version                                                             
check_status_before_run check_new_iredmail

Again, it's recommend to always use the latest iRedMail release. is it that hard to get a CentOS 6 instead of your 5.9?

Thanks for the pointer on script change.

Scheduling makes going to Centos 6 iffy. Agree Centos 6 better long term choice.

8

Re: iRedMail-0.8.5 has been released

ckwong wrote:

Thanks for the pointer on script change.

Well, just updated iRedMail script to control this with variable 'CHECK_NEW_IREDMAIL'. For example, to bypass check new version:

# CHECK_NEW_IREDMAIL=NO bash iRedMail.sh