1

Topic: Roundcube unable to connect to DB after upgrade

==== Required information ====
- iRedMail version: 0.8.1
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): MySQL
- Linux/BSD distribution name and version: Ubuntu 12.10
- Related log if you're reporting an issue: don't know - advice please?
====

I tried to follow the instructions at: http://www.iredmail.org/wiki/index.php? … be.Webmail

to update Roundcube from 0.7.2 to 0.9.0

Couldn't upgrade Roundcube database structure as instructed because there is no "mysql.update.sql" in Roundcube 0.9.0.  Instead I ran the three most recent upgrade scripts in /SQL/mysql which seem to have the same purpose.

Everything seemed to work without error.

However, attempting to access Roundcube now gives:
DATABASE ERROR: CONNECTION FAILED!
Unable to connect to the database!
Please contact your server-administrator.

Now I'm lost - please help!

Gordon

2

Re: Roundcube unable to connect to DB after upgrade

wghay wrote:

there is no "mysql.update.sql" in Roundcube 0.9.0

Oops, Roundcube-0.9.0 splits "mysql.update.sql" into several SQL files under /SQL/mysql/, all SQL files have comment about which version it applies to. For example, file /SQL/mysql/2011111600.sql:

-- Updates from version 0.7-beta
wghay wrote:

DATABASE ERROR: CONNECTION FAILED!

Did you sync settings in roundcubemail-0.9.0/config/db.inc.php with old config file?

3

Re: Roundcube unable to connect to DB after upgrade

ZhangHuangbin wrote:
wghay wrote:

there is no "mysql.update.sql" in Roundcube 0.9.0

Oops, Roundcube-0.9.0 splits "mysql.update.sql" into several SQL files under /SQL/mysql/, all SQL files have comment about which version it applies to. For example, file /SQL/mysql/2011111600.sql:

-- Updates from version 0.7-beta
wghay wrote:

DATABASE ERROR: CONNECTION FAILED!

Did you sync settings in roundcubemail-0.9.0/config/db.inc.php with old config file?

Yes, I was careful about that.
I've now discovered that somehow the Roundcube credentials for MySQL had been lost;  issuing
"GRANT ALL PRIVILEGES on roundcubemail.* TO roundcube@localhost IDENTIFIED BY 'pass';"
seems to have corrected the problem.

Many thanks for your quick response!

Gordon