1

Topic: Issue (IMAP maybe?): Inbox (and other folders) empty in Roundcube.

==== ==== Required information ====
- iRedMail version: 0.8.6
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): MySQL
- Linux/BSD distribution name and version: Debian Squeeze
- Related log if you're reporting an issue:
==== ==== ==== ==== ==== ====

Hello.

As I said above, my server uses iRedMail v0.8.6 (Debian Squeeze).
Since a few days ago I upgraded Debian (aptitude safe-upgrade) and since that day I have had problems with Roundcube.

The problem is simple to describe. When I get access the webmail (Roundcube) both the Inbox and all my other folders appear to be empty, however using POP3 shows me that I have several emails and I download these without problems.
This is using version 0.7 of Roundcube, if I use the latest version (0.8.6) I can't get access (login) (put user & password, [Enter] but nothing, login form again...), however does not show me any errors.

Does anyone have any idea about it?

If someone needs to put a log I gladly do, but I already check in /usr/share/apache2/roundcubemail/logs/ and this folder is empty 0_oU

Thank you very much, I hope someone can help me.

Best regards.

PS: Sorry for my english, it's not my primary language.

2

Re: Issue (IMAP maybe?): Inbox (and other folders) empty in Roundcube.

kzkggaara wrote:

I already check in /usr/share/apache2/roundcubemail/logs/ and this folder is empty

Roundcube is configured to log via syslog by default. It logs to Postfix log file /var/log/mail.log.

3

Re: Issue (IMAP maybe?): Inbox (and other folders) empty in Roundcube.

ZhangHuangbin wrote:

Roundcube is configured to log via syslog by default. It logs to Postfix log file /var/log/mail.log.

I checked /var/log/mail.log and says nothing regarding IMAP or Roundcube. Displays only log regarding incoming and outgoing emails, but nothing concerning Roundcube:

Mar 29 15:31:26 My-Server postfix/smtp[5630]: C6EF83A6023: host mailin-02.mx.aol.com[205.188.155.110] refused to talk to me: 554- (RTR:BL)  http://postmaster.info.aol.com/errors/554rtrbl.html 554  Connecting IP: -Servers IP-
Mar 29 15:31:26 My-Server postfix/smtp[5630]: C6EF83A6023: host mailin-04.mx.aol.com[64.12.90.66] refused to talk to me: 554- (RTR:BL)  http://postmaster.info.aol.com/errors/554rtrbl.html 554  Connecting IP: -Servers IP-
Mar 29 15:31:26 My-Server postfix/smtp[5630]: C6EF83A6023: host mailin-02.mx.aol.com[205.188.190.1] refused to talk to me: 554- (RTR:BL)  http://postmaster.info.aol.com/errors/554rtrbl.html 554  Connecting IP: -Servers IP-
Mar 29 15:31:27 My-Server postfix/smtp[5630]: C6EF83A6023: host mailin-03.mx.aol.com[205.188.190.2] refused to talk to me: 554- (RTR:BL)  http://postmaster.info.aol.com/errors/554rtrbl.html 554  Connecting IP: -Servers IP-
Mar 29 15:31:28 My-Server postfix/local[5629]: 847B7CA14B: to=<root@My-Server-Complete-Hostname>, relay=local, delay=490, delays=487/0.02/0/2.7, dsn=4.3.0, status=deferred (temporary failure)
Mar 29 15:31:30 My-Server postfix/smtp[5630]: C6EF83A6023: to=<xrlq1@aol.com>, relay=mailin-01.mx.aol.com[205.188.146.193]:25, delay=21469, delays=21468/0.01/1.6/0, dsn=4.0.0, status=deferred (host mailin-01.mx.aol.com[205.188.146.193] refused to talk to me: 554- (RTR:BL)  http://postmaster.info.aol.com/errors/554rtrbl.html 554  Connecting IP: -Servers IP-)
Mar 29 15:38:05 My-Server postfix/smtpd[24804]: connect from whv01.red.cult.cu[200.0.24.32]
Mar 29 15:38:07 My-Server postfix/smtpd[24804]: 2D3CD3A6005: client=whv01.red.cult.cu[200.0.24.32]
Mar 29 15:38:10 My-Server postfix/smtpd[24804]: disconnect from whv01.red.cult.cu[200.0.24.32]
Mar 29 15:38:42 My-Server postfix/pipe[25639]: 2D3CD3A6005: to=<me@mydomain.net>, relay=dovecot, delay=36, delays=3.8/0.01/0/32, dsn=2.0.0, status=sent (delivered via dovecot service)
Mar 29 15:38:42 My-Server postfix/qmgr[309]: 2D3CD3A6005: removed
Mar 29 15:39:07 My-Server postfix/pickup[31406]: DDFB53A6005: uid=0 from=<root>
Mar 29 15:39:07 My-Server postfix/cleanup[25400]: DDFB53A6005: message-id=<20130329153907.DDFB53A6005@My-Server-Complete-Hostname>
Mar 29 15:39:20 My-Server postfix/qmgr[309]: DDFB53A6005: from=<root@My-Server-Complete-Hostname>, size=760, nrcpt=1 (queue active)
Mar 29 15:39:24 My-Server postfix/local[28840]: DDFB53A6005: to=<root@My-Server-Complete-Hostname>, relay=local, delay=23, delays=19/0.02/0/4.2, dsn=4.3.0, status=deferred (temporary failure)

Thanks for your help.

4

Re: Issue (IMAP maybe?): Inbox (and other folders) empty in Roundcube.

kzkggaara wrote:

I checked /var/log/mail.log and says nothing regarding IMAP or Roundcube. Displays only log regarding incoming and outgoing emails, but nothing concerning Roundcube:

Any related log in Apache log files (/var/log/apache2/*)?

5

Re: Issue (IMAP maybe?): Inbox (and other folders) empty in Roundcube.

kzkggaara wrote:

==== ==== Required information ====
- iRedMail version: 0.8.6
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): MySQL
- Linux/BSD distribution name and version: Debian Squeeze
- Related log if you're reporting an issue:
==== ==== ==== ==== ==== ====

Hello.

As I said above, my server uses iRedMail v0.8.6 (Debian Squeeze).
Since a few days ago I upgraded Debian (aptitude safe-upgrade) and since that day I have had problems with Roundcube.

The problem is simple to describe. When I get access the webmail (Roundcube) both the Inbox and all my other folders appear to be empty, however using POP3 shows me that I have several emails and I download these without problems.
This is using version 0.7 of Roundcube, if I use the latest version (0.8.6) I can't get access (login) (put user & password, [Enter] but nothing, login form again...), however does not show me any errors.

Does anyone have any idea about it?

If someone needs to put a log I gladly do, but I already check in /usr/share/apache2/roundcubemail/logs/ and this folder is empty 0_oU

Thank you very much, I hope someone can help me.

Best regards.

PS: Sorry for my english, it's not my primary language.

Check if you have mod_pagespeed enabled on your system.
I had the same problem with CentOS updating from 6.3 to 6.4.
It somehow breaks mod_pagespeed, I had it installed on my system but had to remove it, as roundcube was showing no email in any folder...

6

Re: Issue (IMAP maybe?): Inbox (and other folders) empty in Roundcube.

still with issues...
Now I cant login, here some log from mail.info:

Apr  1 16:12:31 vs2777 roundcube: IMAP Error: Login failed for me@mydomain.net from MY-IP-ADD(X-Forwarded-For: ISP-IP-ADD). AUTHENTICATE PLAIN:  in /usr/share/apache2/roundcubemail-0.7/program/include/rcube_imap.php on line 205 (POST /?_task=login&_action=login)

ZhangHuangbin: No, nothing in /var/log/apache2/roundcube_*.log

Albux: Thanks, I already remove mod_pagespeed from the server.

Please help ... this situation is killing me T_T

7

Re: Issue (IMAP maybe?): Inbox (and other folders) empty in Roundcube.

kzkggaara wrote:

AUTHENTICATE PLAIN:

Please try using 'LOGIN' as imap_auth_type instead of 'PLAIN' or auto in Roundcube config file (config/main.inc.php):

$rcmail_config['imap_auth_type'] = 'login';