1

Topic: sa-update erro - Freebsd 9 amd64

==== Required information ====
- iRedMail version: 0.8.3
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): LDAP
- Linux/BSD distribution name and version: Freebsd 9 amd64
- Related log if you're reporting an issue:
====

Hi,

I installed a virtual server with Freebsd 9-RELEASE AMD64.
When i finished the installation and i ran sa-update command, i received this erro:

root@mail:/root # sa-update
http: GET 3.3 request failed: 400 URL must be absolute: 400 URL must be absolute
error: no mirror data available for channel updates.spamassassin.org
channel: MIRRORED.BY contents were missing, channel failed


What can be? I reinstalled spamassassin and not work.
Without this, amavis do not start.

Thanks a lot.

2

Re: sa-update erro - Freebsd 9 amd64

Looks like update mirror was down. Please try to run it later, or choose another update mirror.
Reference: http://www.gossamer-threads.com/lists/s … ers/166787

3

Re: sa-update erro - Freebsd 9 amd64

Hi Zhang,

I installed again in another virtual server and do not work yet.
But in my production server works fine.
Can be a problema with installation of spamassassin?
Follows my version of spamassaassin:

[root@test ~]# pkg_info  | grep -i spamassassin
p5-Mail-SpamAssassin-3.3.2_6 A highly efficient mail filter for identifying spam


Without this, amavis do not start.
Log of amavis:

amavis[1256]: (!!)TROUBLE in pre_loop_hook: config: no rules were found!  Do you need to run 'sa-update'?
amavis[1256]: (!)_DIE: Suicide () TROUBLE in pre_loop_hook: config: no rules were found!  Do you need to run 'sa-update'?

4 (edited by jorge 2012-12-15 03:43:34)

Re: sa-update erro - Freebsd 9 amd64

Hi Zhang,

I found this link https://issues.apache.org/SpamAssassin/ … ction=diff
I modified into the file /usr/local/bin/sa-update  and works fine.
Amavis start now.

Thanks for help.