1

Topic: Fixed in 0.5.1: Incorrect crontab job of vmail user.

This post is used to fix bug in iRedMail. if it doesn't work for you, please post a new topic in iRedMail General Technical Support forum.
=================

Abstract:
- There will be a file permission error if you enable below crontab job (it's disabled by default) of vmail user:

#1   5   *   *   *   find /var/virusmails -ctime +30 | xargs rm -rf {}

We'd like to thank jbou for his report. smile

Affected versions:

- iRedMail-0.5.1
- iRedMail-0.5.0
- iRedOS-0.5.0

Steps to fix it:

  • Add same cron job of amavis user.

# ---- Run below command in terminal ----
# sudo crontab -e -u amavis

# ---- RHEL/CentOS ----
1   5   *   *   *   find /var/virusmails -ctime +30 | xargs rm -rf {}

# ---- Debian/Ubuntu ----
1   5   *   *   *   find /var/lib/amavis/virusmails -ctime +30 | xargs rm -rf {}

If you don't want to enable it, just prepend '#' in this line to comment it.

  • Comment out or delete this cron job of vmail user.

# ---- Run below command in terminal ----
# sudo crontab -e -u vmail

2

Re: Fixed in 0.5.1: Incorrect crontab job of vmail user.

Update:

  • 2010-01-23: On Debian/Ubuntu: virusmails directory should be /var/lib/amavis/virusmails. Thanks to Przemyslaw Nowakowski (pnowako@) for his report.