1 (edited by hoho 2009-11-06 17:13:49)

Topic: upgrade 0.5.0 > 0.5.1 error on python-ldap ERROR

When typing in command

easy_install python-ldap==2.3.8


Error messages:
[root@mail etc]# easy_install python-ldap==2.3.8
Searching for python-ldap==2.3.8
Reading http://cheeseshop.python.org/pypi/python-ldap/
Reading http://www.python-ldap.org/
Reading http://cheeseshop.python.org/pypi/python-ldap/2.3.10
No local packages or download links found for python-ldap==2.3.8
error: Could not find suitable distribution for Requirement.parse('python-ldap==2.3.8')

2

Re: upgrade 0.5.0 > 0.5.1 error on python-ldap ERROR

Try 'easy_install python-ldap==2.3.9'.

3

Re: upgrade 0.5.0 > 0.5.1 error on python-ldap ERROR

sames error

[root@mail ~]# easy_install python-ldap==2.3.9
Searching for python-ldap==2.3.9
Reading http://cheeseshop.python.org/pypi/python-ldap/
Reading http://www.python-ldap.org/
Reading http://cheeseshop.python.org/pypi/python-ldap/2.3.10
No local packages or download links found for python-ldap==2.3.9
error: Could not find suitable distribution for Requirement.parse('python-ldap==2.3.9')

4

Re: upgrade 0.5.0 > 0.5.1 error on python-ldap ERROR

Could you please try below steps to install it?

  • Download python-ldap-2.3.9 from pypi

# wget http://pypi.python.org/packages/source/p/python-ldap/python-ldap-2.3.9.tar.gz
  • And then uncompress it

# tar zxf python-ldap-2.3.9.tar.gz
  • Change directory to the new directory, run python script to install it

# cd python-ldap-2.3.9
# python setup.py install