1

Topic: Lost admin panel

I seem to have lost my admin panel for some reason.

I am now getting a 404 error when accessing any https service.

Haven't used it in a while so I am guessing I am having a senior moment.

Yes I did look at the iRedMail.tips file

Any comments would be helpful.

Regards

Fred

2

Re: Lost admin panel

Could you please post related apache log?

3

Re: Lost admin panel

ZhangHuangbin wrote:

Could you please post related apache log?

The /var/log/apache2/ssl_access.log is empty

The error.log and other_vhosts_access.log are also empty.
The access.log file does contain data but is not relavent to the problem.

Part of iRedMail.tips
PostfixAdmin:
    * Configuration files:
        - /usr/share/apache2/postfixadmin-2.2.1.1
        - /usr/share/apache2/postfixadmin-2.2.1.1/config.local.php
        - /usr/share/apache2/postfixadmin-2.2.1.1/config.inc.php
    * Login account:
        - Username: ??????????@??????????, password: **********
    * URL:
        - https://mail1.corpcomp.co.nz/postfixadmin/
    * See also:
        - /etc/apache2/conf.d/postfixadmin.conf

This is on a production server, so with my very limited knowledge I am understandably cautious about doing anything to it for fear of making it rather terminal.

The only mod I have done is changed the port from 80 to 3001 as I am behind a NAT firewall with a single IP and I have an apache server as well as the iRedMail server.

In file /etc/apache2/sites-enabled/000-default I changed
<VirtualHost *:3001>

I did not make any changes to /etc/apache2/sites-enabled/default-ssl

Regards

Fred

4

Re: Lost admin panel

I don't know why it happened. sad