1

Topic: ClamAV-0.97.5 is now available for upgrading on RHEL/CentOS/Scientific

Dear all,

ClamAV-0.97.5 is now available for your upgrading on RHEL/CentOS/Scientific Linux (both 5.x and 6.x), all users are encouraged to upgrade this security related component as soon as possible.

You can upgrade it with below commands:

# yum clean metadata
# yum update 'clamav*'

It will upgrade 3 packages: clamd, clamav, clamav-db.

After upgraded, please update ClamAV database and restart ClamAV services immediately:

# freshclam
# /etc/init.d/freshclamd restart
# /etc/init.d/clamd restart

That's all.

2

Re: ClamAV-0.97.5 is now available for upgrading on RHEL/CentOS/Scientific

Just update clamav-0.97.5 and i cannot send/receive email anymore...below is the maillog messages

Jun 29 10:02:57 iredos amavis[2125]: (02125-01) (!)ClamAV-clamd: Can't connect to UNIX socket /tmp/clamd.socket: Connection refused, retrying (2)
Jun 29 10:03:03 iredos amavis[2125]: (02125-01) (!)ClamAV-clamd av-scanner FAILED: run_av error: Too many retries to talk to /tmp/clamd.socket (Can't connect to UNIX socket /tmp/clamd.socket: Connection refused) at (eval 105) line 373.\n
Jun 29 10:03:03 iredos amavis[2125]: (02125-01) (!!)WARN: all primary virus scanners failed, considering backups
Jun 29 10:03:03 iredos amavis[2125]: (02125-01) (!)run_av (ClamAV-clamscan) FAILED - unexpected exit 2, output="WARNING: Ignoring deprecated option --disable-summary\nERROR: Option --tempdir requires a non-empty string argument\nERROR: Can't parse command line options"
Jun 29 10:03:03 iredos amavis[2125]: (02125-01) (!)ClamAV-clamscan av-scanner FAILED: /usr/bin/clamscan unexpected exit 2, output="WARNING: Ignoring deprecated option --disable-summary\nERROR: Option --tempdir requires a non-empty string argument\nERROR: Can't parse command line options" at (eval 105) line 594.
Jun 29 10:03:03 iredos amavis[2125]: (02125-01) (!!)TROUBLE in check_mail: virus_scan FAILED: AV: ALL VIRUS SCANNERS FAILED
Jun 29 10:03:03 iredos amavis[2125]: (02125-01) (!)PRESERVING EVIDENCE in /var/amavis/tmp/amavis-20120629T100255-02125

3

Re: ClamAV-0.97.5 is now available for upgrading on RHEL/CentOS/Scientific

I have to manually delete /tmp/clamd.socket and restart server then can send/receive email...i will keep on monitor it

4

Re: ClamAV-0.97.5 is now available for upgrading on RHEL/CentOS/Scientific

Oops, sorry about my mistake, forgot to mention that restarting ClamAV service is required.

5

Re: ClamAV-0.97.5 is now available for upgrading on RHEL/CentOS/Scientific

ZhangHuangbin wrote:

Oops, sorry about my mistake, forgot to mention that restarting ClamAV service is required.


After the first problem happen I restart the server, still the problem exist. I have to manually delete /tmp/clamd.socket than restart server again to solve the problem...

6

Re: ClamAV-0.97.5 is now available for upgrading on RHEL/CentOS/Scientific

In case someone gets "ERROR: Broken or not a CVD file" when trying to restart clamd, the fix is below.

"Stopping Clam AntiVirus Daemon:                            [FAILED]
Starting Clam AntiVirus Daemon: LibClamAV Error: cli_cvdverify: Can't read CVD header
LibClamAV Error: Can't load /var/clamav/main.cvd: Broken or not a CVD file
ERROR: Broken or not a CVD file"

To fix this you need to run : /usr/bin/freshclam -v

After all updates you should see :
WARNING: Clamd was NOT notified: Can't connect to clamd through /tmp/clamd.socket
connect(): No such file or directory

Run : /etc/init.d/clamd ; /etc/init.d/freshclam restart  - and everything should be ok.

7

Re: ClamAV-0.97.5 is now available for upgrading on RHEL/CentOS/Scientific

Dear hata_ph, ColdAslce,

Thanks very much for your feedback and solution, updated my first post above. smile