1 (edited by agattei 2012-05-24 21:31:36)

Topic: Problem upgrading iRedAdmin-0.1.6 to iRedAdmin-Pro-MySQL-1.4.0

Hi Zhang,
I've purchased the pro version and I've tryed to update my iRedAdmin free version.
I have do all the steps of the tutorial (http://www.iredmail.org/wiki/index.php? … ro/OSE-Pro) but after restarting apache the admin panel doesn't work.

I've got a generic 500 internal server error when I try to open the url:

https://MYDOMAIN.TLD/iredadmin

Can you help me?

Thanks a lot,
Alessio Gattei

==== Provide required information ====
- iRedMail version and backend (LDAP/MySQL/PGSQL): 0.7.4 updated to 0.8.0 - MySQL
- Linux/BSD distribution name and version: CentOS 6.2 64 bit
- Any related log? Log is helpful for troubleshooting.

/var/log/httpd/ssl_error_log

[Thu May 24 15:28:40 2012] [error] [client x.x.x.x] mod_wsgi (pid=18806): Target WSGI script '/var/www/iredadmin/iredadmin.py' cannot be loaded as Python module.
[Thu May 24 15:28:40 2012] [error] [client x.x.x.x] mod_wsgi (pid=18806): Exception occurred processing WSGI script '/var/www/iredadmin/iredadmin.py'.
[Thu May 24 15:28:40 2012] [error] [client x.x.x.x] Traceback (most recent call last):
[Thu May 24 15:28:40 2012] [error] [client x.x.x.x]   File "/var/www/iredadmin/iredadmin.py", line 9, in <module>
[Thu May 24 15:28:40 2012] [error] [client x.x.x.x]     from libs import iredbase
[Thu May 24 15:28:40 2012] [error] [client x.x.x.x]   File "/var/www/iredadmin/libs/iredbase.py", line 34, in <module>
[Thu May 24 15:28:40 2012] [error] [client x.x.x.x]     webmaster = cfg.general.get('webmaster', 'root')
[Thu May 24 15:28:40 2012] [error] [client x.x.x.x]   File "/usr/lib/python2.6/site-packages/web/utils.py", line 76, in __getattr__
[Thu May 24 15:28:40 2012] [error] [client x.x.x.x]     raise AttributeError, k
[Thu May 24 15:28:40 2012] [error] [client x.x.x.x] AttributeError: 'general'
[Thu May 24 15:28:40 2012] [error] [client x.x.x.x] File does not exist: /var/www/html/favicon.ico

====

2

Re: Problem upgrading iRedAdmin-0.1.6 to iRedAdmin-Pro-MySQL-1.4.0

I'm sorry, I've made a mistake, I did chown -R 0555 and not chmod -R 0555.
Now seems to work fine.

Best regards,
Alessio Gattei