1

Topic: Vacation message not working for In-Domain emails

==== Provide required information to help troubleshoot and get quick answer ====
- Linux/BSD distribution name and version: CentOS 5.7
- iRedMail version and backend (LDAP/MySQL): 0.7.1 / MySQL
- Any related log? Log is helpful for troubleshooting.
====

Hello,

When an user (john) of example.com domain sets vacation message from roundcube filter, users sending email from outside of example.com (like yahoo.com, gmail.com etc) getting the "out of office" auto-reply. But when another user (brian) of example.com sends email to this user (john), he doesn't get any auto-reply message. It's happening on all 400 virtual-domains.

Thanks.

2

Re: Vacation message not working for In-Domain emails

It's not working as designed.

Could you please:
- paste the vacation setting (sieve filter rule)
- paste whole content of file /etc/dovecot-mysql.conf.

Also, please:
- turn on debug mode in /etc/dovecot.conf (mail_debug = yes)
- monitor its log file (/var/log/sieve.log)
- send a testing email
- paste related log in /var/log/sieve.log

P.S. It's recommended to upgrade iRedMail to the latest iRedMail-0.7.4, there's a bug fix related to sieve:
http://iredmail.org/wiki/index.php?titl … in_Dovecot