1

Topic: Problem field _quota_cur database postfixpolicyd

==== Provide required information to help troubleshoot and get quick answer ====
- Linux/BSD distribution name and version:
- iRedMail version and backend (LDAP/MySQL):
- Any related log? Log is helpful for troubleshooting.
====


Good afternoon my name is Adelmir Mucelin, I have a problem on my mail server, I'm the utlizando iRedAdmin-Pro with postfix, but every day a certain period of my problem Quota exceeded e-mail, I made several attempts to solve my problem, I checked and the problem is in the database "postfixpolicyd" in the "throttle" the attribute "_quota_cur" it came with a default value I modificiquei this value to "73374798" and every time I send an email it back the default value so the problem occurs again exceeded quota-mail if someone can help me to fix this problem e-mail quota exceeded.

thank you==== Provide required information to help troubleshoot and get quick answer ====
- Linux/BSD distribution name and version:
- iRedMail version and backend (LDAP/MySQL):
- Any related log? Log is helpful for troubleshooting.
====

2

Re: Problem field _quota_cur database postfixpolicyd

Did you change quota setting in Policyd config file? It should be /etc/postfix-policyd.conf on Debian/Ubuntu.

3 (edited by ademucelin 2012-03-01 03:05:54)

Re: Problem field _quota_cur database postfixpolicyd

Yes, I've changed the configurations of the back and always the same error, for example where the problem I'm going straight at the base mysql and run the following command:

UPDATE `` postfixpolicyd. `Throttle` SET `_quota_cur` = '101033876 '

Give back to run the e-mail again.

Besides this problem I have another problem that when you send a large number of e-mail it returns an email to the sender blank, I believe is an error, but nothing comes even in the title or the body of the email.

I am posting attached my config files.

If you can help me I am grateful.

hug

4

Re: Problem field _quota_cur database postfixpolicyd

ademucelin wrote:

the problem is in the database "postfixpolicyd" in the "throttle" the attribute "_quota_cur" it came with a default value

What's the default value?

You can find some default limits in Policyd config file:

SENDERMSGLIMIT=50000
SENDERRCPTLIMIT=50000
SENDERQUOTALIMIT=250000000
SENDERTIMELIMIT=1h
RECIPIENTMSGLIMIT=50000
RECIPIENTTIMELIMIT=1h

Please change them to fit your need. Here's detailed tutorial: http://policyd.sourceforge.net/readme.html

Also, could you post the original quota exceed message here?

5

Re: Problem field _quota_cur database postfixpolicyd

Hello, _quota_cur the field did not come with any default value in the database.

segua below an error message that happens when I send enough mail.


The message WAS NOT relayed to:
  <sedenova@minhaempresa.com.br>: [127.0.0.1] said:
   554 5.7.1 Failed, id=32647-01, from MTA([127.0.0.1]:10025): 554 5.7.1 <END-OF-MESSAGE>: End-of-data rejected: Policy Rejection-  10-Cota de e-mail excedida.

This nondelivery report was generated by the program amavisd-new at host
mail.minhaempresa.com.br. Our internal reference code for your message is
32647-01/bFlI-fq0K-cy

Return-Path: <informativo@minhaempresa.com.br>
From: Informativo <informativo@minhaempresa.com.br>
Message-ID: <4F4D3D03.80504@minhaempresa.com.br>
Subject: TITULO EMAIL



dsn_status

Reporting-MTA: dns; mail.minhaempresa.com.br
Received-From-MTA: smtp; mail.minhaempresa.com.br ([127.0.0.1])
Arrival-Date: Tue, 28 Feb 2012 17:57:31 -0300 (BRT)

Original-Recipient: rfc822;sedenova@minhaempresa.com.br
Final-Recipient: rfc822;sedenova@minhaempresa.com.br
Action: failed
Status: 5.7.1
Remote-MTA: dns; 127.0.0.1
Diagnostic-Code: smtp; 554 5.7.1 <END-OF-MESSAGE>: End-of-data rejected: Policy Rejection-  10-Cota de e-mail excedida.
Last-Attempt-Date: Tue, 28 Feb 2012 17:57:31 -0300 (BRT)
Final-Log-ID: 32647-01/bFlI-fq0K-cy


header

Return-Path: <informativo@minhaempresa.com.br>
Received: from [192.168.1.60] (unknown [192.168.1.60])
    (using TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits))
    (No client certificate requested)
    by mail.minhaempresa.com.br (Postfix) with ESMTPSA id E09E05124;
    Tue, 28 Feb 2012 17:45:53 -0300 (BRT)
Message-ID: <4F4D3D03.80504@minhaempresa.com.br>
Date: Tue, 28 Feb 2012 17:45:55 -0300
From: Informativo <informativo@minhaempresa.com.br>
Reply-To: informativo@minhaempresa.com.br
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.9.1.9) Gecko/20100317 Thunderbird/3.0.4
MIME-Version: 1.0
To: destinatarios-nao-revelados:;
Subject: TITULO EMAIL
assembleares
Content-Type: multipart/mixed;
boundary="------------010508050301050101040403"

6

Re: Problem field _quota_cur database postfixpolicyd

Could you please show me the output of below command:

# postconf smtpd_end_of_data_restrictions

Also, if you have Policyd enabled in smtpd_end_of_data_restrictions, please paste its config file here to help troubleshoot (REMOVE/HIDE MySQL username/password and other sensitive information before posting).

Could you help translate this log message? I don't understand the last few words.

<END-OF-MESSAGE>: End-of-data rejected: Policy Rejection-  10-Cota de e-mail excedida.

7

Re: Problem field _quota_cur database postfixpolicyd

Good morning,

the command you told me to do this generated output below:

smtpd_end_of_data_restrictions check_policy_service = inet: 127.0.0.1:10032


I'm sending the configuration files as requested.

The message that I posted before is that email has exceeded quota.

thank you

Post's attachments

Conf.zip 11.93 kb, 1 downloads since 2012-03-02 

You don't have the permssions to download the attachments of this post.

8

Re: Problem field _quota_cur database postfixpolicyd

Could you please try fixing it with below steps:

1) Open /etc/postfix/master.cf, find below lines:

127.0.0.1:10025 inet n  -   -   -   -  smtpd
    ...
    -o smtpd_client_restrictions=permit_mynetworks,reject
    -o smtpd_helo_restrictions=
    -o smtpd_sender_restrictions=
    ...

2) Append one line after '-o smtpd_sender_restrictions=' like below:

127.0.0.1:10025 inet n  -   -   -   -  smtpd
    ...
    -o smtpd_client_restrictions=permit_mynetworks,reject
    -o smtpd_helo_restrictions=
    -o smtpd_sender_restrictions=
    -o smtpd_end_of_data_restrictions=
    ...

3) Restart Postfix service.

9

Re: Problem field _quota_cur database postfixpolicyd

ok, I made the alterations as I described and see if solves my problem. Beyond this quota problem I have another email that is sent when a large number of emails it always returns a few emails with no information, is attached a picture of my thunderbird back to you see how the error. It follows the source code of the email that returns blank.

thank you

Source code email:

From - Thu Mar  1 16:07:36 2012
X-Account-Key: account3
X-UIDL: 000009e64f02da28
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00000000
X-Mozilla-Keys:                                                                                 
Return-Path: <informativo@meusite.com.br>
Delivered-To: informativo@meusite.com.br
Received: from localhost (localhost [127.0.0.1])
    by mail.meusite.com.br (Postfix) with ESMTP id 47AD07623;
    Thu,  1 Mar 2012 16:03:33 -0300 (BRT)
Message-Id: <20120301190333.47AD07623@mail.meusite.com.br>
Date: Thu,  1 Mar 2012 16:03:33 -0300 (BRT)
From: informativo@meusite.com.br
To: undisclosed-recipients:;

10

Re: Problem field _quota_cur database postfixpolicyd

Still no idea at all, sorry. Is there any server-side log of this issue?

11

Re: Problem field _quota_cur database postfixpolicyd

Good afternoon esteemed colleague, I did the modification as above this line

smtpd_end_of_data_restrictions

but my email quota problem continues look in the log server below:

Mar  9 11:10:33 mail postfix-policyd: rcpt=10398, throttle=abuse(f), host=192.168.1.81, from=meusite@meusite.com.br, to=, size=254738/15728640, quota=101033876/250000000, count=100000/100000(100000), rcpt=100000/100000(100000), threshold=40%|100%|100%, sasl_username=meusite@meusite.com.br
Mar  9 11:10:33 mail postfix/smtpd[29399]: 20F4E1041B5: reject: END-OF-MESSAGE from unknown[192.168.1.81]: 554 5.7.1 <END-OF-MESSAGE>: End-of-data rejected: Policy Rejection-  Quota exceeded e-mail.; from=<meusite@meusite.com.br> proto=ESMTP helo=<[192.168.1.81]>
Mar  9 11:10:33 mail postfix-policyd: connection from: 127.0.0.1 port: 45826 slots: 3 of 4096 used
Mar  9 11:10:33 mail postfix-policyd: rcpt=17245, greylist=update, host=189.2.28.114 (fwsrv.domaniinfo.com.br), from=superlinha@santander.com.br, to=jane@meusite.com.br, size=6033
Mar  9 11:10:33 mail postfix-policyd: rcpt=17245, throttle_rcpt=update(a), host=189.2.28.114, from=superlinha@santander.com.br, to=jane@meusite.com.br, count=89/100000(4), threshold=0%
Mar  9 11:10:33 mail postfix-policyd: rcpt=17246, greylist=new, host=189.38.96.8 (mailserver3.itake.net.br), from=leni@erechim.com.br, to=adriane.munari@meusite.com.br, size=0
Mar  9 11:10:34 mail postfix/smtpd[2715]: NOQUEUE: reject: RCPT from vt-0008-172.virtualtarget.com.br[187.61.36.172]: 450 4.7.1 <india@meusite.com.br>: Recipient address rejected: Policy Rejection- Por favor, tente mais tarde.; from=<dma_5322@dma2.virtualtarget.com.br> to=<india@meusite.com.br> proto=ESMTP helo=<vt-0008-172.virtualtarget.com.br>


I'm waiting for some other solution.

thank you

12

Re: Problem field _quota_cur database postfixpolicyd

ademucelin wrote:

Mar  9 11:10:33 mail postfix-policyd: rcpt=10398, throttle=abuse(f), host=192.168.1.81, from=meusite@meusite.com.br, to=, size=254738/15728640, quota=101033876/250000000, count=100000/100000(100000), rcpt=100000/100000(100000), threshold=40%|100%|100%, sasl_username=meusite@meusite.com.br

Is there any restriction in Policyd database for user "meusite@meusite.com.br" or domain "@meusite.com.br"?

You can also add a restriction for this user (or domain), increase rcpt count to a number lager than 100000.
Reference: http://policyd.sourceforge.net/readme.html