1 (edited by ppot 2011-10-24 02:58:50)

Topic: Centos el5 dovecot 1.2.16 to 1.2.17 latest update bug.

==== Provide basic information to help troubleshoot ====
- iRedMail version:
- Linux/BSD distribution name and version:
- Any related log? Log is helpful for troubleshooting.
====
after yum update with iRedMail repo i have in log:
dovecot: managesieve-login: Fatal: Dovecot version mismatch: Master is v1.2.17, login is v1.2.16 (if you don't care, set version_ignore=yes)
and managesieve ofcourse doesn't work.

2

Re: Centos el5 dovecot 1.2.16 to 1.2.17 latest update bug.

So sorry about this issue, upstream didn't rebuild dovecot-managesieve, so i didn't import it into yum repo.
Reversed to dovecot-1.2.16 in yum repo, you can backup config filees, then remove 1.2.17 and re-install it.

3 (edited by ppot 2011-10-26 02:04:12)

Re: Centos el5 dovecot 1.2.16 to 1.2.17 latest update bug.

this problem can also be overcome without downgrade dovecot to version 1.2.16, although this is an ugly solution, you can replace in the binaries Managesieve and Managesieve-login (installed from iRedMail repo) all entries of "1.2.16" to "1.2.17" and everything works like before the update ...