1

Topic: Disabling Aliases to send mails.

Hi,

I am facing one Issue.

I wanna block aliases from sending emails.

group@example.com is an Alias.

Following is the tests which I did :

#################################################
telnet mail.example.com 25
Trying mail.example.com...
Connected to mail.example.com.
Escape character is '^]'.
220 mail.example.com ESMTP Postfix
helo mail.example.com
250 mail.example.com
mail from:<group@example.com>
250 2.1.0 Ok
rcpt to:<group@example.com>
250 2.1.5 Ok
Data
354 End data with <CR><LF>.<CR><LF>
.
250 2.0.0 Ok: queued as 3452322C8503

quit
221 2.0.0 Bye
Connection closed by foreign host.
################################################

Please suggest.

2

Re: Disabling Aliases to send mails.

Shashank wrote:

group@example.com is an Alias.

mail from:<group@example.com>
250 2.1.0 Ok

If "group@example.com" is an alias, why Postfix know it as a mail user (it was passed in "mail from:")?

- Is there a mail user with same email address?
- Does your mail server check address in "mail from:"? Please make sure you have Postfix setting "smtpd_sender_login_maps".