1 (edited by cbstech 2011-10-15 06:53:02)

Topic: Can't receive mails. - storage quota exceeded

==== Provide basic information to help troubleshoot ====
- iRedMail version: 0.7.3
- Linux/BSD distribution name and version: Ubuntu 10.04
- Any related log? Log is helpful for troubleshooting.

Hello, I set up a new iRedMail system last week, and have not been able to get it to receive emails from an external domain (gmail, hotmail, yahoo...). It sends just fine. I can also send to addresses on the same server just fine.


Re: Can't receive mails. - storage quota exceeded

It reports "Storage quota exceeded" in bounce mail. Was you hard disk full?

If mailbox quota exceeded, it will return message "Quota exceeded" instead of "Storage quota exceeded".

3 (edited by cbstech 2011-10-14 08:23:54)

Re: Can't receive mails. - storage quota exceeded

ZhangHuangbin wrote:

It reports "Storage quota exceeded" in bounce mail. Was you hard disk full?

If mailbox quota exceeded, it will return message "Quota exceeded" instead of "Storage quota exceeded".

It reports 31.5GB free.


Re: Can't receive mails. - storage quota exceeded

No idea yet. Could you please post output of below commands to help troubleshoot:

# postconf -n
# dovecot -n


Re: Can't receive mails. - storage quota exceeded

Here is my postconf -n

alias_database = hash:/etc/postfix/aliases
alias_maps = hash:/etc/postfix/aliases
allow_min_user = no
append_dot_mydomain = no
biff = no
bounce_queue_lifetime = 1d
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
content_filter = smtp-amavis:[]:10024
delay_warning_time = 0h
disable_vrfy_command = yes
enable_original_recipient = no
home_mailbox = Maildir/
inet_interfaces = all
inet_protocols = ipv4
mailbox_command = /usr/lib/dovecot/deliver
mailbox_size_limit = 0
maximal_backoff_time = 4000s
maximal_queue_lifetime = 1d
message_size_limit = 15728640
minimal_backoff_time = 300s
mydestination = $myhostname, localhost, localhost.localdomain, localhost.$myhostname
mydomain = cbsvcare.com
myhostname = mail.cbsvcare.com
mynetworks =
mynetworks_style = subnet
myorigin = mail.cbsvcare.com
proxy_read_maps = $canonical_maps $lmtp_generic_maps $local_recipient_maps $mydestination $mynetworks $recipient_bcc_maps $recipient_canonical_maps $relay_domains $relay_recipient_maps $relocated_maps $sender_bcc_maps $sender_canonical_maps $smtp_generic_maps $smtpd_sender_login_maps $transport_maps $virtual_alias_domains $virtual_alias_maps $virtual_mailbox_domains $virtual_mailbox_maps $smtpd_sender_restrictions
queue_run_delay = 300s
readme_directory = no
recipient_bcc_maps = proxy:mysql:/etc/postfix/mysql/recipient_bcc_maps_domain.cf, proxy:mysql:/etc/postfix/mysql/recipient_bcc_maps_user.cf
recipient_delimiter = +
relay_domains = $mydestination, proxy:mysql:/etc/postfix/mysql/relay_domains.cf
relayhost =
sender_bcc_maps = proxy:mysql:/etc/postfix/mysql/sender_bcc_maps_domain.cf, proxy:mysql:/etc/postfix/mysql/sender_bcc_maps_user.cf
smtp_data_init_timeout = 240s
smtp_data_xfer_timeout = 600s
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
smtpd_data_restrictions = reject_unauth_pipelining
smtpd_enforce_tls = no
smtpd_helo_required = yes
smtpd_helo_restrictions = permit_mynetworks,permit_sasl_authenticated, check_helo_access pcre:/etc/postfix/helo_access.pcre
smtpd_recipient_restrictions = reject_unknown_sender_domain, reject_unknown_recipient_domain, reject_non_fqdn_sender, reject_non_fqdn_recipient, reject_unlisted_recipient, check_policy_service inet:, permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination, reject_non_fqdn_helo_hostname, reject_invalid_helo_hostname, check_policy_service inet:
smtpd_reject_unlisted_recipient = yes
smtpd_reject_unlisted_sender = yes
smtpd_sasl_auth_enable = yes
smtpd_sasl_authenticated_header = no
smtpd_sasl_local_domain =
smtpd_sasl_path = ./dovecot-auth
smtpd_sasl_security_options = noanonymous
smtpd_sasl_type = dovecot
smtpd_sender_login_maps = proxy:mysql:/etc/postfix/mysql/sender_login_maps.cf
smtpd_sender_restrictions = permit_mynetworks, reject_sender_login_mismatch, permit_sasl_authenticated
smtpd_tls_CAfile = /etc/ssl/certs/iRedMail_CA.pem
smtpd_tls_cert_file = /etc/ssl/certs/iRedMail_CA.pem
smtpd_tls_key_file = /etc/ssl/private/iRedMail.key
smtpd_tls_loglevel = 0
smtpd_tls_security_level = may
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes
tls_random_source = dev:/dev/urandom
transport_maps = proxy:mysql:/etc/postfix/mysql/transport_maps_user.cf, proxy:mysql:/etc/postfix/mysql/transport_maps_domain.cf
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql/virtual_alias_maps.cf, proxy:mysql:/etc/postfix/mysql/domain_alias_maps.cf, proxy:mysql:/etc/postfix/mysql/catchall_maps.cf, proxy:mysql:/etc/postfix/mysql/domain_alias_catchall_maps.cf
virtual_gid_maps = static:1001
virtual_mailbox_base = /var/vmail
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql/virtual_mailbox_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql/virtual_mailbox_maps.cf
virtual_minimum_uid = 1001
virtual_transport = dovecot
virtual_uid_maps = static:1001


Re: Can't receive mails. - storage quota exceeded

When I try to get the dovecot -n I get an error. If I run it using sudo this is what I get:

# 1.2.15: /etc/dovecot/dovecot.conf
# OS: Linux 2.6.38-11-generic i686 Ubuntu 11.04
log_path: /var/log/dovecot.log
protocols: pop3 pop3s imap imaps managesieve
listen(default): *
listen(imap): *
listen(pop3): *
ssl_ca_file: /etc/ssl/certs/iRedMail_CA.pem
ssl_cert_file: /etc/ssl/certs/iRedMail_CA.pem
ssl_key_file: /etc/ssl/private/iRedMail.key
disable_plaintext_auth: no
login_dir: /var/run/dovecot/login
login_executable(default): /usr/lib/dovecot/imap-login
login_executable(imap): /usr/lib/dovecot/imap-login
login_executable(pop3): /usr/lib/dovecot/pop3-login
login_executable(managesieve): /usr/lib/dovecot/managesieve-login
first_valid_uid: 1001
last_valid_uid: 1001
mail_uid: 1001
mail_gid: 1001
mail_location: maildir:/%Lh/Maildir/:INDEX=/%Lh/Maildir/
mbox_write_locks: fcntl dotlock
mail_executable(default): /usr/lib/dovecot/imap
mail_executable(imap): /usr/lib/dovecot/imap
mail_executable(pop3): /usr/lib/dovecot/pop3
mail_executable(managesieve): /usr/lib/dovecot/managesieve
mail_process_size: 1024
mail_plugins(default): quota imap_quota autocreate
mail_plugins(imap): quota imap_quota autocreate
mail_plugins(pop3): quota
mail_plugin_dir(default): /usr/lib/dovecot/modules/imap
mail_plugin_dir(imap): /usr/lib/dovecot/modules/imap
mail_plugin_dir(pop3): /usr/lib/dovecot/modules/pop3
mail_plugin_dir(managesieve): /usr/lib/dovecot/modules/managesieve
imap_client_workarounds(default): tb-extra-mailbox-sep
imap_client_workarounds(imap): tb-extra-mailbox-sep
pop3_client_workarounds(pop3): outlook-no-nuls oe-ns-eoh
  type: private
  separator: /
  inbox: yes
  list: yes
  subscriptions: yes
  type: shared
  separator: /
  prefix: Shared/%%u/
  location: maildir:/%%Lh/Maildir/:INDEX=/%%Lh/Maildir/Shared/%%u
  list: children
  subscriptions: yes
  postmaster_address: root
  auth_socket_path: /var/run/dovecot/auth-master
  mail_plugins: quota sieve autocreate
  sieve_global_path: /var/vmail/sieve/dovecot.sieve
  log_path: /var/log/sieve.log
auth default:
  mechanisms: plain login
  default_realm: cbsvcare.com
  user: vmail
    driver: sql
    args: /etc/dovecot/dovecot-mysql.conf
    driver: sql
    args: /etc/dovecot/dovecot-mysql.conf
    type: listen
      path: /var/spool/postfix/dovecot-auth
      mode: 438
      user: postfix
      group: postfix
      path: /var/run/dovecot/auth-master
      mode: 438
      user: vmail
      group: vmail
  quota_warning: storage=85%% /usr/local/bin/dovecot-quota-warning.sh 85
  quota_warning2: storage=90%% /usr/local/bin/dovecot-quota-warning.sh 90
  quota_warning3: storage=95%% /usr/local/bin/dovecot-quota-warning.sh 95
  quota: dict:user::proxy::quotadict
  quota_rule: *:storage=0
  expire: Trash 7 Trash/* 7 Junk 30
  expire_dict: proxy::expire
  auth_socket_path: /var/run/dovecot/auth-master
  sieve: /var/vmail/sieve/%Ld/%Ln/dovecot.sieve
  autocreate: INBOX
  autocreate2: Sent
  autocreate3: Trash
  autocreate4: Drafts
  autocreate5: Junk
  autosubscribe: INBOX
  autosubscribe2: Sent
  autosubscribe3: Trash
  autosubscribe4: Drafts
  autosubscribe5: Junk
  acl: vfile
  acl_shared_dict: proxy::acl
  sieve: /var/vmail/sieve/%Ld/%Ln/dovecot.sieve
  sieve_dir: /var/vmail/sieve/%Ld/%Ln/
  expire: db:/var/lib/dovecot/expire/expire.db
  quotadict: mysql:/etc/dovecot/dovecot-used-quota.conf
  acl: mysql:/etc/dovecot/dovecot-share-folder.conf


Re: Can't receive mails. - storage quota exceeded

I just noticed I posted the wrong error.....oops and sorry. Here is the right error.

This is an automatically generated Delivery Status Notification



Delivery to the following recipient has been delayed:


Message will be retried for 2 more day(s)

Technical details of temporary failure:
The recipient server did not accept our requests to connect. Learn more at http://mail.google.com/support/bin/answ … nswer=7720
[mail.cbsvcare.com. (10): Connection timed out]

----- Original message -----

MIME-Version: 1.0
Received: by with SMTP id hx8mr4277911qcb.123.1318389886893;
Tue, 11 Oct 2011 20:24:46 -0700 (PDT)
Received: by with HTTP; Tue, 11 Oct 2011 20:24:46 -0700 (PDT)
In-Reply-To: <ca16ff9f609b6daaac778ea888c423bd@cbsvcare.com>
References: <ca16ff9f609b6daaac778ea888c423bd@cbsvcare.com>
Date: Tue, 11 Oct 2011 20:24:46 -0700
Message-ID: <CAEPzwJTyhaxDmp6er7Yhh=7bbeFNB5i3iBOR_LAstaR74j6mag@mail.gmail.com>
Subject: Re: test to hm
From: My Name <*@gmail.com>
To: *@cbsvcare.com
Content-Type: multipart/alternative; boundary=0016361e8242e23cfd04af11907a


Re: Can't receive mails. - storage quota exceeded

cbstech wrote:

[mail.cbsvcare.com. (10): Connection timed out]

It means Gmail cannot connect to your server. It's a network issue, please check your server network, make sure it's available from external network. Also, make sure your Postfix service is running.


Re: Can't receive mails. - storage quota exceeded

I figured it out today. Thanks Zhang, your suggestion to make sure postfix was running lead me to where I needed to go.

I tried to restart postfix, when I got an error about message_size_limit. I deleted the trailing 0 and restarted again.

Now it works like a charm.

Feel free to mark this solved.