1

Topic: Hostname

==== Provide basic information to help troubleshoot ====
- iRedMail version: 0.7.3
- Linux/BSD distribution name and version: Ubuntu 10.04
- Any related log? Log is helpful for troubleshooting.
====

When I telnet to my machine on port 587 I get this:

220 samedaygaragedoors.com ESMTP Postfix (Ubuntu)

So it appears that the machine thinks it is "samedaygaragedoors.com". What I would really like is for the machine to think that it is "spf.samedaygaragedoors.com". Is it possible to do this? Where can I find information on how to manually configure hostname settings for the entire iRedMail package? Is there some documentation available?

Thanks!

2

Re: Hostname

change it in your  : /etc/hosts

type : hostname -f to see your FQDN.

3

Re: Hostname

You should also reload the hostname by executing /etc/init.d/hostname.sh and check all the iRedMail-related config files, such as:
- /etc/postfix/main.cf [e. g. the value for "myhostname"]
- /etc/amavis/conf.d/50-user [e. g. the value for "@local_domains_maps"]
- /etc/mailname
... to be absolutely sure you've got every setting.

Maybe you want the correct (self-generated) SSL certificates, too?! Then you need to execute the bash script called generate_ssl_keys.sh within the iRedMail-x.x.x/tools folder.