1 (edited by udi111 2011-09-03 00:36:16)

Topic: 0.7.0 database problem?

hi,

i use 0.7.0 with mysql backend, on debian squeeze 64.
the server was up since months, without problems.
this morning something went wrong, nobody could send or receive mails.
i found this in the mail.log:

postfix/smtpd[7074]: warning: connect to 127.0.0.1:7777: Connection refused

after restarting the server everything was ok.

i read in the forums that this was because iredapd was not running.
it's really interesting what happened that stopped iredapd, i did not do any system updates or anything in the last months.

later today i noticed that roundcube stops working randomly, it prints an error message about database error, a few seconds later everything is ok again.
this happened a few times this afternoon.

please help me to find what causes these problems.

thanks
adam

edit:
i found lines like these in the log:
Sep  2 16:12:08 mail roundcube: MDB2 Error: unknown error (-1): _doConnect: [Error message: Too many connections]#012[Native code: 1040]#012[Native message: Too many connections]
Sep  2 16:12:08 mail roundcube: DB Error: _doConnect: [Error message: Too many connections]#012[Native code: 1040]#012[Native message: Too many connections]#012 ** mysqli(mysqli)://roundcube:xxx@localhost/roundcubemail in /usr/share/apache2/roundcubemail-0.5.1/program/include/rcube_mdb2.php on line 101 (GET /?_task=mail)

2

Re: 0.7.0 database problem?

i found this in the forums:

http://www.iredmail.org/forum/topic1972 … denly.html

that fix is for 0.7.1.
can i apply it to my 0.7.0?

thanks
adam

3

Re: 0.7.0 database problem?

It should be fine. (BACKUP before testing)

4

Re: 0.7.0 database problem?

thank you for your answer.

i applied the patch and until now everything seems working smile

another question:

in 0.7.0, when the server starts, sometimes postfix-policyd starts before mysql and drops error messages in the log.
in this case i have to restart the service manually.

is this fixed in the newer versions?

thank you
adam

5

Re: 0.7.0 database problem?

udi111 wrote:

in 0.7.0, when the server starts, sometimes postfix-policyd starts before mysql and drops error messages in the log.
in this case i have to restart the service manually.

Of course you can.

udi111 wrote:

is this fixed in the newer versions?

This is a Debian/Ubuntu bug in /etc/init.d/postfix-policyd, you can help create a bug ticket in http://launchpad.net/
You can also change start order in /etc/init.d/postfix-policyd manually.