1

Topic: Can't log in to Roundcube (stuck on "Loading")

I am very close to getting iRedMail working. However, right now, I can't login to Roundcube with ANY users.

LDAP is working fine, I can connect via phpmyldap.

It hangs on the "Loading" screen, and I can never log in. There is nothing published to ANY of my error logs. I can't login on port 80 OR port 443.

My alias on default-ssl (in sites-enabled):

Alias /mail "/usr/share/apache2/roundcubemail/"
Alias /ldap_admin "/usr/share/phpldapadmin/"
Alias /sql_admin "/usr/share/phpmyadmin/"
Alias /mail_stats/icon "/usr/share/awstats/icon/"
ScriptAlias /mail_stats "/usr/lib/cgi-bin/awstats/"
WSGIScriptAlias /mail_admin "/usr/share/apache2/iredadmin/iredadmin.py/"
Alias /mail_admin/static "/usr/share/apache2/iredadmin/static/"

Is my alias to roundcubemail correct? Right now I have "force_https" set to true, but it also fails with it set to "false".

2

Re: Can't log in to Roundcube (stuck on "Loading")

Alias is correct.
Please check logs in Apache and Roundcube.

3

Re: Can't log in to Roundcube (stuck on "Loading")

ZhangHuangbin wrote:

Alias is correct.
Please check logs in Apache and Roundcube.

==== Provide basic information to help troubleshoot ====
- iRedMail version:
- Linux/BSD distribution name and version:
- Any related log? Log is helpful for troubleshooting.
====

Where are roundcube logs? In "/var/log" somewhere?

4 (edited by sam-the-man 2011-08-01 22:32:25)

Re: Can't log in to Roundcube (stuck on "Loading")

I see that there are no logs in:

<roundcube_base>/logs/errors

sad

I have changed loglevel in roundcube conf from "1" to "8". I have also changed:

// Log successful logins to <log_dir>/userlogins or to syslog
$rcmail_config['log_logins'] = false;

// Log session authentication errors to <log_dir>/session or to syslog
$rcmail_config['log_session'] = false;

from 'false' to 'true'.

EDIT: hopefully that gives me some errors in the log. Like I said, I have nothing there!! very hard to trace this issue.

5 (edited by sam-the-man 2011-08-01 22:48:13)

Re: Can't log in to Roundcube (stuck on "Loading")

Here's an update:

When I click login, browser says "Waiting for www.mydomain.com/mail..." but nothing ever happens. It just stops trying to load after awhile. It's not even publishing any debugging information, or anything to the logs.

It must be an apache problem, any suggestions on where to look? Why isn't this issue writing anything to any error logs?

Zhang: You have been very helpful so far. If this error persists, I will not keep asking about it. I will nuke my server again later and start over. Attempt number 7 might work!!

6

Re: Can't log in to Roundcube (stuck on "Loading")

Roundcube logs into Postfix log file by default, it should be /var/log/maillog, /var/log/mail.log or /var/log/mail, not <roundcube_base>/logs/*.