1 (edited by siddartha.g 2011-07-19 14:34:22)

Topic: Pureftpd showing everything under the directory.

Hi,
This is another problem while I am testing the pureftpd which is integrated with iredmail,
while I have typed "ftp://192.168.1.10"(my ftp and iredmail server) in browser from my local machine, it is showing everything under /home/ftp directory without asking any user name and passwords, which is expected to not.

Please correct me if I am wrong.

Regards
siddartha.g

2

Re: Pureftpd showing everything under the directory.

Did you set any permissions about anonymous user?

3

Re: Pureftpd showing everything under the directory.

ZhangHuangbin wrote:

Did you set any permissions about anonymous user?

No, I have not set any permissions like that.
Where exactly I can find them Zhang?

Regards
siddartha.g

4

Re: Pureftpd showing everything under the directory.

If you have anonymous ftp access enabled, and /home/ftp is HOME directory of anonymous account, then it will be accessible.
If this is not what you expect, try to change HOME directory of this anonymous account.

5

Re: Pureftpd showing everything under the directory.

I have not enabled anonymous ftp, still I will to recheck those settings and I will post the same here.

Please give me the location where I can find them (settings belongs to anonymous ftp and home directory)

6

Re: Pureftpd showing everything under the directory.

Sorry, I suggest asking normal PureFTPd questions in its mail list or forum.

7 (edited by siddartha.g 2011-07-20 17:43:05)

Re: Pureftpd showing everything under the directory.

Its ok Zhang,
I have solved the problem in the following way
terminal commands

->apt-get purge pure-ftpd-ldap
->apt-get purge ftp
->find / -name "ftp" -exec rm -rf  {} \;
->userdel -r ftp

and followed the same tutorial http://www.iredmail.org/wiki/index.php? … DAP/Ubuntu

and finally its working and anonymous logins are disabled.
it may help some one.

Regards
siddartha.g