1

Topic: Error on Centos 5.5 and PHP 5.3

Hi to everyone, i'm trying this new "SERVER" world smile

I have a problem with iRedMail and my Server.
My Server is Centos 5.5, with MySql 5.1.56, Php 5.3.6 and other packages like squirrelmail, dovecont, pure-ftp, antispam, antivirus, postfix, ispconfig, webmin etc...
everything work fine, i have some websites online...
Now i discovery this fantastic application iRedMail, but i can't install it.
i followed http://code.google.com/p/iredmail/wiki/Installation but when i use

# bash iRedMail.sh, complete configuration (i use MySql, and set only roundcube app),

and start Installing Packages... then...i've this error
[...]
---> Package perl-XML-SAX.noarch 0:0.14-8 set to be updated
--> Processing Dependency: perl(XML::NamespaceSupport) for package: perl-XML-SAX
---> Package php-mhash.i386 0:5.2.17-1.el5.art set to be updated
--> Processing Dependency: php-common = 5.2.17-1.el5.art for package: php-mhash
--> Running transaction check
---> Package perl-XML-NamespaceSupport.noarch 0:1.09-1.2.1 set to be updated
---> Package php-mhash.i386 0:5.2.17-1.el5.art set to be updated
--> Processing Dependency: php-common = 5.2.17-1.el5.art for package: php-mhash
--> Finished Dependency Resolution
php-mhash-5.2.17-1.el5.art.i386 from atomic has depsolving problems
  --> Missing Dependency: php-common = 5.2.17-1.el5.art is needed by package php-mhash-5.2.17-1.el5.art.i386 (atomic)
Error: Missing Dependency: php-common = 5.2.17-1.el5.art is needed by package php-mhash-5.2.17-1.el5.art.i386 (atomic)
[...]

Anyone have same problem ? Somebody have RESOLVED this problem ?

Thanks to everyone, and sorry for my bad english wink

Andrea

2

Re: Error on Centos 5.5 and PHP 5.3

You should edit functions/packages.sh to let iRedMail not to install PHP related packages.

Also, please backup your server data first.

3

Re: Error on Centos 5.5 and PHP 5.3

Great !!! THANKS !!!

now iRedMail (only roundcubemail for now) is installed... but new problem sad

when i go on www.MyHostName.com/mail or another roundcube alias
i have a blank page...

Any suggest ? sad

4

Re: Error on Centos 5.5 and PHP 5.3

I'm looking on web ... (googleeeee wink

and i try to show errors...

I'm going to edit mysql access and some username

DB Error in /var/www/roundcubemail-0.5.1/program/include/rcube_mdb2.php (101): _doConnect: [Error message: Access denied for user 'root'@'localhost' (using password: YES)]
[Native code: 1045]
[Native message: Access denied for user 'root'@'localhost' (using password: YES)]
** mysqli(mysqli)://root:xxx@localhost/roundcubemail
Warning: session_start(): Cannot send session cache limiter - headers already sent in /var/www/roundcubemail-0.5.1/program/include/rcmail.php on line 592 Fatal error: Cannot redeclare class password in /var/www/roundcubemail-0.5.1/plugins/password/password.php on line 257 DB Error in /var/www/roundcubemail-0.5.1/program/include/rcube_mdb2.php (101): _doConnect: [Error message: Access denied for user 'root'@'localhost' (using password: YES)]
[Native code: 1045]
[Native message: Access denied for user 'root'@'localhost' (using password: YES)]
** mysqli(mysqli)://root:xxx@localhost/roundcubemail
DB Error in /var/www/roundcubemail-0.5.1/program/include/rcube_mdb2.php (101): _doConnect: [Error message: Access denied for user 'root'@'localhost' (using password: YES)]
[Native code: 1045]
[Native message: Access denied for user 'root'@'localhost' (using password: YES)]
** mysqli(mysqli)://root:xxx@localhost/roundcubemail

See you later, with good news... hi hope wink

5

Re: Error on Centos 5.5 and PHP 5.3

Now password it's ok ...

but

Fatal error: Cannot redeclare class password in /var/www/roundcubemail-0.5.1/plugins/password/password.php on line 257

sad

6

Re: Error on Centos 5.5 and PHP 5.3

ZIZU wrote:

Fatal error: Cannot redeclare class password in /var/www/roundcubemail-0.5.1/plugins/password/password.php on line 257

Do you have php-mcrypt and php-mhash installed?

7

Re: Error on Centos 5.5 and PHP 5.3

php-mcrypt Yes
Package php-mcrypt-5.3.6-2.el5.art.i386 already installed and latest version

only problem maybe is php-mhash...
when i installed iRedMail i remove in packages php-common becouse request:
- php-mhash-5.2.17-1.el5.art.i386
I try with yum install php-mhash ...

php-mhash-5.2.17-1.el5.art.i386 from atomic has depsolving problems
  --> Missing Dependency: php-common = 5.2.17-1.el5.art is needed by package php-mhash-5.2.17-1.el5.art.i386 (atomic)

but i have
php-common-5.3.6-2.el5.art.i386 already installed and latest version

sad

8

Re: Error on Centos 5.5 and PHP 5.3

ZIZU wrote:

Now password it's ok ...

but

Fatal error: Cannot redeclare class password in /var/www/roundcubemail-0.5.1/plugins/password/password.php on line 257

sad

I ran into this same problem. I think it happens after running the setup more than once.

Edit the main.inc.php file, in my setup it is located at /usr/share/apache2/roundcubemail/config

Find these lines:

// List of active plugins (in plugins/ directory)
$rcmail_config['plugins'] = array("password","managesieve",);

Make sure the array only has one instance of each plugin.