1

Topic: installation failed

root@mail:/home/silent/Downloads/iRedMail-0.6.1/pkgs# bash get_all.sh
< INFO > Creating necessary directories ...
< INFO > ==================== Fetching Source Tarballs ====================
< INFO > * 1/5: http://iredmail.org/apt/misc/postfixadmin_2.3.tar.gz
< INFO > * 2/5: http://iredmail.org/apt/misc/iRedAdmin-0.1.3.tar.bz2
< INFO > * 3/5: http://iredmail.org/apt/misc/iRedAPD-1.3.3.tar.bz2
< INFO > * 4/5: http://iredmail.org/apt/misc/roundcubemail-0.3.1.tar.gz
< INFO > * 5/5: http://iredmail.org/apt/misc/phpldapadmin-1.2.0.5.tgz
< INFO > Validate Packages ... [ OK ]
< INFO > Checking necessary command/package: dialog/dialog ...
< INFO > Installing package(s): dialog
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package dialog is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'dialog' has no installation candidate
< ERROR > Installation failed, please check the terminal output

plis somebody to help me...thanks in advance

2 (edited by shake 2011-03-11 22:08:44)

Re: installation failed

check you yum setting.

then run

yum list

http://www.iredmail.org/forum/topic1724 … lable.html

3

Re: installation failed

Seems you are running Debian or Ubuntu, your apt repositories are not correctly set up, please follow iredmail installation guide strictly.

4

Re: installation failed

Package phpapi-20060613+lfs is a virtual package provided by:
  libapache2-mod-php5filter 5.2.6.dfsg.1-3ubuntu4.6 [Not candidate version]
  php5-cli 5.2.6.dfsg.1-3ubuntu4.6 [Not candidate version]
  php5-cgi 5.2.6.dfsg.1-3ubuntu4.6 [Not candidate version]
  libapache2-mod-php5 5.2.6.dfsg.1-3ubuntu4.6 [Not candidate version]
  libapache2-mod-php5filter 5.2.6.dfsg.1-3ubuntu4 [Not candidate version]
  php5-cli 5.2.6.dfsg.1-3ubuntu4 [Not candidate version]
  php5-cgi 5.2.6.dfsg.1-3ubuntu4 [Not candidate version]
  libapache2-mod-php5 5.2.6.dfsg.1-3ubuntu4 [Not candidate version]
  php5-cli 5.2.4-2ubuntu5.14 [Not candidate version]
  php5-cgi 5.2.4-2ubuntu5.14 [Not candidate version]
  libapache2-mod-php5 5.2.4-2ubuntu5.14 [Not candidate version]
  php5-cli 5.2.4-2ubuntu5 [Not candidate version]
  php5-cgi 5.2.4-2ubuntu5 [Not candidate version]
  libapache2-mod-php5 5.2.4-2ubuntu5 [Not candidate version]

E: Package 'phpapi-20060613+lfs' has no installation candidate

somebody pliss...what does it mean by that..???thanks in advance

5

Re: installation failed

http://code.google.com/p/iredmail/wiki/ … _on_Ubuntu

follow the guide to do.

6

Re: installation failed

check your source

/etc/apt/source.list

Both 'main' and 'universe' repositories are required.

some vps seem would disable the universe by default.