1

Topic: iRedAPD not working

Hi all :-),

Let me explain my configuration:

iRedMail 1.4 + OpenLDAP + iRedAPD 1.3.3

When I enable iRedAPD as per official configuration I don't receive any messages. Tracking iRedAPD I get to the following output on log files:

==> /var/log/iredapd.log <==
2011-02-19 12:41:59 DEBUG Connect from 127.0.0.1
2011-02-19 12:41:59 DEBUG smtp session: request=smtpd_access_policy
2011-02-19 12:41:59 DEBUG smtp session: protocol_state=RCPT
2011-02-19 12:41:59 DEBUG smtp session: protocol_name=ESMTP
2011-02-19 12:41:59 DEBUG smtp session: client_address=209.85.161.175
2011-02-19 12:41:59 DEBUG smtp session: client_name=mail-gx0-f175.google.com
2011-02-19 12:41:59 DEBUG smtp session: reverse_client_name=mail-gx0-f175.google.com
2011-02-19 12:41:59 DEBUG smtp session: helo_name=mail-gx0-f175.google.com
2011-02-19 12:41:59 DEBUG smtp session: sender=aa@aa.com
2011-02-19 12:41:59 DEBUG smtp session: recipient=bb@bb.com
2011-02-19 12:41:59 DEBUG smtp session: recipient_count=0
2011-02-19 12:41:59 DEBUG smtp session: queue_id=
2011-02-19 12:41:59 DEBUG smtp session: instance=683.4d5fac87.adc6a.0
2011-02-19 12:41:59 DEBUG smtp session: size=0
2011-02-19 12:41:59 DEBUG smtp session: etrn_domain=
2011-02-19 12:41:59 DEBUG smtp session: stress=
2011-02-19 12:41:59 DEBUG smtp session: sasl_method=
2011-02-19 12:41:59 DEBUG smtp session: sasl_username=
2011-02-19 12:41:59 DEBUG smtp session: sasl_sender=
2011-02-19 12:41:59 DEBUG smtp session: ccert_subject=
2011-02-19 12:41:59 DEBUG smtp session: ccert_issuer=
2011-02-19 12:41:59 DEBUG smtp session: ccert_fingerprint=
2011-02-19 12:41:59 DEBUG smtp session: encryption_protocol=TLSv1
2011-02-19 12:41:59 DEBUG smtp session: encryption_cipher=RC4-SHA
2011-02-19 12:41:59 DEBUG smtp session: encryption_keysize=128
2011-02-19 12:41:59 DEBUG LDAP connection initialied success.
2011-02-19 12:41:59 DEBUG LDAP bind success.
2011-02-19 12:41:59 DEBUG __get_recipient_dn_ldif (recipient): bb@bb.com
2011-02-19 12:41:59 DEBUG __get_recipient_dn_ldif (result): [('mail=bb@bb.com,ou=Users,.....]
2011-02-19 12:41:59 DEBUG Apply plugin (ldap_maillist_access_policy).
2011-02-19 12:41:59 DEBUG Response from plugin (ldap_maillist_access_policy): DUNNO
2011-02-19 12:41:59 DEBUG Apply plugin (block_amavisd_blacklisted_senders).
2011-02-19 12:41:59 DEBUG Response from plugin (block_amavisd_blacklisted_senders): DUNNO
2011-02-19 12:41:59 DEBUG Final action: None.
2011-02-19 12:41:59 INFO aa@aa.com -> bb@bb.com, DUNNO
2011-02-19 12:41:59 DEBUG Connection closed

==> /var/log/iredapd-rr.log <==
2011-02-19 12:41:59 DEBUG Connect from 127.0.0.1
2011-02-19 12:41:59 DEBUG smtp session: request=smtpd_access_policy
2011-02-19 12:41:59 DEBUG smtp session: protocol_state=RCPT
2011-02-19 12:41:59 DEBUG smtp session: protocol_name=ESMTP
2011-02-19 12:41:59 DEBUG smtp session: client_address=209.85.161.175
2011-02-19 12:41:59 DEBUG smtp session: client_name=mail-gx0-f175.google.com
2011-02-19 12:41:59 DEBUG smtp session: reverse_client_name=mail-gx0-f175.google.com
2011-02-19 12:41:59 DEBUG smtp session: helo_name=mail-gx0-f175.google.com
2011-02-19 12:41:59 DEBUG smtp session: sender=aa@aa.com
2011-02-19 12:41:59 DEBUG smtp session: recipient=bb@bb.com
2011-02-19 12:41:59 DEBUG smtp session: recipient_count=0
2011-02-19 12:41:59 DEBUG smtp session: queue_id=
2011-02-19 12:41:59 DEBUG smtp session: instance=683.4d5fac87.adc6a.0
2011-02-19 12:41:59 DEBUG smtp session: size=0
2011-02-19 12:41:59 DEBUG smtp session: etrn_domain=
2011-02-19 12:41:59 DEBUG smtp session: stress=
2011-02-19 12:41:59 DEBUG smtp session: sasl_method=
2011-02-19 12:41:59 DEBUG smtp session: sasl_username=
2011-02-19 12:41:59 DEBUG smtp session: sasl_sender=
2011-02-19 12:41:59 DEBUG smtp session: ccert_subject=
2011-02-19 12:41:59 DEBUG smtp session: ccert_issuer=
2011-02-19 12:41:59 DEBUG smtp session: ccert_fingerprint=
2011-02-19 12:41:59 DEBUG smtp session: encryption_protocol=TLSv1
2011-02-19 12:41:59 DEBUG smtp session: encryption_cipher=RC4-SHA
2011-02-19 12:41:59 DEBUG smtp session: encryption_keysize=128
2011-02-19 12:41:59 DEBUG LDAP connection initialied success.
2011-02-19 12:41:59 DEBUG LDAP bind success.
2011-02-19 12:41:59 DEBUG __get_sender_dn_ldif (sender):
2011-02-19 12:41:59 DEBUG __get_sender_dn_ldif: Sender is not a valid email address.
2011-02-19 12:41:59 DEBUG Sender DN or LDIF is none.
2011-02-19 12:41:59 DEBUG Final action: DUNNO.
2011-02-19 12:41:59 INFO aa@aa.com -> bb@bb.com, DUNNO
2011-02-19 12:41:59 DEBUG Connection closed


As far as I understand it, iRedAPD seems ok, the problem comes with iRedAPD-rr which does not seem to be ok, it cannot find something on LDAP (last lines). Before activating iRedAPD everything was working ok, so my understanding is that somehting in iRedAPD is wrong.

Can someone help me?

Regards