1

Topic: Having Trouble Installing 0.7.0 beta

I used winscp to upload beta 7.0 when I tried to uncompress it I tried these commands

tra xjf iRedMail-0.7.0.-beta1.tar.bz2  (unknown)

I treid:

tra xjf iRedMail-0.7.0.beta1.tar.bz2 (unknown)
tar xjf iRedMail-0.7.0.tar.bz2

Nothing works  Under the 6.0 it is just supposed to be

tar xjf iRedMail-0.6.0.tar.bz2

So how do I get this to decompress and work?

Please, Please , Help

2

Re: Having Trouble Installing 0.7.0 beta

What's the uploaded filename on your remote server?

3

Re: Having Trouble Installing 0.7.0 beta

The upload file name is  iRedMail-0.7.0-beta1.tar.bz2   as you can see from above I tried this and it would not work.

I tried       # tar xfj iRedMail-0.7.0-beta1.tar.bz2     Is there something I am missing here with this command. 

Since it is the upload link in my server it should work..Correct?   But it does not

ZhangHuangbin wrote:

What's the uploaded filename on your remote server?

4

Re: Having Trouble Installing 0.7.0 beta

what os do you use?

you can try to install bzip2.

yum install bzip2
or
apt-get install bzip2

5

Re: Having Trouble Installing 0.7.0 beta

Using Cento5...Should I try to see if I can install 0.6.0 to see if it will install and then try to upgarde?

6

Re: Having Trouble Installing 0.7.0 beta

Keeps telling me can not locate...no such directory.  However it is showing in my  winscp as being there.  Is there something else I need to do.  I tried to install bzip2 no luck

7

Re: Having Trouble Installing 0.7.0 beta

Hi:   I went in and deleted the package I uploaced through winscrp..Starting getting results.  I got the iRedMail and Pkgs uploaded.  I then did the Yum Repository check...Ok There.

When I go to the next step from my instructions.(http://code.google.com/p/iredmail/wiki/Installation)  I get the error message below:

[root@server pkgs]# cd /path/to/iRedMail-0.7.0-beta1
-bash: cd: /path/to/iRedMail-0.7.0-beta1: No such file or directory
[root@server pkgs]

The only thing I can think of is if I am missing a command .   However, I can't see any missing commands in the above mentioned instullation guide.

So can you tell me what is wrong so that I can go forward? 

I really appreciate the assistance.

8

Re: Having Trouble Installing 0.7.0 beta

Sorry.  I should have re-read that before I posted.   After I deleted the uploads I did with winscp I then went to wget http://iRedMail.googlecode.com/files/iR … a1.tar.bz2 and it started working, until I ran into the above problem.

9

Re: Having Trouble Installing 0.7.0 beta

Did you replace '/path/to/iRedMail-0.7.0-beta1' by real path on your server?

10

Re: Having Trouble Installing 0.7.0 beta

Yes I did replace the path but it is still not working.

11

Re: Having Trouble Installing 0.7.0 beta

Ok I typed the path in after the prompt.  cd /path/to/iRedMail-0.7.0-beta1...So do I need to do something different to replace '/path/to/iRedMail-0.7.0-beta1'  by real path on server?   I just can't get it to work...Please help me get this working

12

Re: Having Trouble Installing 0.7.0 beta

I found the command to replace it is tar-xvjf iRedMail-0.7.0-beta1
cd iRedMail-0.7.0-beta1  - Now how do I find the directory.   I was in root and then just unpacked iredmail through wget.  I have tried find.name iredmail-typef but nothing seems to brigh up the directory.   Can you give some help here

13

Re: Having Trouble Installing 0.7.0 beta

I found IT!   [root@server /]# find . -type d -name iRedMail
./var/cache/yum/iRedMail
[root@server /]#  Now lets see if I can get this installed.

14

Re: Having Trouble Installing 0.7.0 beta

What do I do from here I must be missing something because the bash iRedMail.sh comes back as no such file.

I am in the proper directory...[root@server iRedMail  I really need to get this done so please tell me what I am doing wrong.