1

Topic: iRedOS SMTP Banner Problem

Just installed iRedOS and I am having a problem with the banner. Basically, it's not matching the FQDN I have setup for this machine, it's showing localhost.localdomain instead:

220 localhost.localdomain ESMTP iRedMail

I tried changing the 127.0.0.1 entry in /etc/hosts to that of my FQDN, rebooted, but then for whatever reason I am unable to connect to the SMTP server (postfix). It will attempt to connect and then close the connection.

I also uncommented smtpd_banner = $myhostname ESMTP $mail_name in main.cf and restarted postfix with no change.

I'm sure this is a simple fix, but I can't quite put a finger on it.

2

Re: iRedOS SMTP Banner Problem

digilink wrote:

I also uncommented smtpd_banner = $myhostname ESMTP $mail_name in main.cf and restarted postfix with no change.

Change postfix setting 'myhostname' to the correct one.

3

Re: iRedOS SMTP Banner Problem

ZhangHuangbin wrote:

Change postfix setting 'myhostname' to the correct one.

That did the trick. If anyone else ever runs into this, issuing the following command should fix it:

postconf -e myhostname=someserver.example.com

Restart postfix and you should be good to go.

4

Re: iRedOS SMTP Banner Problem

Thanks for the tip, it helped me a lot cause i was really disturbed with always having that message after every smpt test.
You're a blessing