1

Topic: Cannot Delete Domain

Hi,

I am trying to delete a domain but it doesnt get deleted. Tried from the pro version and also from phpldapadmin.

errors:
from phpLDAPAdmin

E_WARNING: Illegal offset type
error    You found a non-fatal phpLDAPadmin bug!
Error:    Undefined variable: request (E_NOTICE)
File:    rdelete.php line 66, caller cmd.php
Versions:    PLA: 1.2.0.5, PHP: 5.3.3, SAPI: apache2handler
Web server:    Apache/2.2.16 (FreeBSD) mod_ssl/2.2.16 OpenSSL/0.9.8n DAV/2 mod_wsgi/2.8 Python/2.6.5

Could not delete the entry. ()
LDAP said:    Other (e.g., implementation specific) error
Error number:    0x50 (LDAP_OTHER)
Description:   
error    You found a non-fatal phpLDAPadmin bug!
Error:    Undefined variable: request (E_NOTICE)
File:    rdelete.php line 66, caller cmd.php
Versions:    PLA: 1.2.0.5, PHP: 5.3.3, SAPI: apache2handler
Web server:    Apache/2.2.16 (FreeBSD) mod_ssl/2.2.16 OpenSSL/0.9.8n DAV/2 mod_wsgi/2.8 Python/2.6.5

2

Re: Cannot Delete Domain

What's the error message in iRedAdmin-Pro?

3

Re: Cannot Delete Domain

ZhangHuangbin wrote:

What's the error message in iRedAdmin-Pro?

No error messages seen in iRedAdmin-Pro web interface if thats what you meant.
Only this (in the URL):
https://domain.com/iredadmin/domains?{u'example.com':%20%22{'info':%20'entry%20index%20delete%20failed',%20'desc':%20'Other%20(e.g.,%20implementation%20specific)%20error'}%22}

Is there a log specific to iredadmin pro ?

Also, sometimes when i try to modify a users account , the same error happens and the client update in unsuccessful.

It seems its more related to LDAP....but i am not sure.

Give me some pointers, i dont know LDAP well yet.

4

Re: Cannot Delete Domain

Which version of iRedMail do you use?
Did you config OpenLDAP to include amavisd ldap schema by following this step?
http://www.iredmail.org/admin_installat … dap-config

5

Re: Cannot Delete Domain

ZhangHuangbin wrote:

Which version of iRedMail do you use?
Did you config OpenLDAP to include amavisd ldap schema by following this step?
http://www.iredmail.org/admin_installat … dap-config

iRedMail-0.6.1

Yes, the above was carried out. I have checked again. All necessary packages are installed and the permissions and ownership are right as per the guide.

Its quite funny actually, it happens for just a few domains and some users. I am able to delete users from ldap but the domain doesnt get deleted from ldap.

I will look into this as soon as i have had some time and will post back the findings.

6

Re: Cannot Delete Domain

rein wrote:
ZhangHuangbin wrote:

Which version of iRedMail do you use?
Did you config OpenLDAP to include amavisd ldap schema by following this step?
http://www.iredmail.org/admin_installat … dap-config

iRedMail-0.6.1

Yes, the above was carried out. I have checked again. All necessary packages are installed and the permissions and ownership are right as per the guide.

Its quite funny actually, it happens for just a few domains and some users. I am able to delete users from ldap but the domain doesnt get deleted from ldap.

I will look into this as soon as i have had some time and will post back the findings.

To my surprise , after just restarting slapd, this started to work as before.
Q: Could this be the due to 10 people using the interface for mail management ? buffers etc