1

Topic: iredOS 0.6.0 roundcube ldap change password

Users can´t change passwords tru roundcube. see the maillog below.

It is a out of the box iRedOS 0.6.0



Sep 13 15:48:22 mail roundcube: PHP Warning:  require_once(Net/LDAP2.php) [<a href='function.require-once'>function.require-once</a>]: failed to open stream: Filen eller katalogen finns inte in /var/www/roundcubemail-0.3.1/plugins/password/drivers/ldap.php on line 20
Sep 13 15:48:22 mail roundcube: PHP Fatal error:  require_once() [<a href='function.require'>function.require</a>]: Failed opening required 'Net/LDAP2.php' (include_path='/var/www/roundcubemail/:/var/www/roundcubemail/program:/var/www/roundcubemail/program/lib:/var/www/roundcubemail/program/include:.:/usr/share/pear:/usr/share/php') in /var/www/roundcubemail-0.3.1/plugins/password/drivers/ldap.php on line 20
Sep 13 15:48:27 mail roundcube: PHP Warning:  require_once(Net/LDAP2.php) [<a href='function.require-once'>function.require-once</a>]: failed to open stream: Filen eller katalogen finns inte in /var/www/roundcubemail-0.3.1/plugins/password/drivers/ldap.php on line 20
Sep 13 15:48:27 mail roundcube: PHP Fatal error:  require_once() [<a href='function.require'>function.require</a>]: Failed opening required 'Net/LDAP2.php' (include_path='/var/www/roundcubemail/:/var/www/roundcubemail/program:/var/www/roundcubemail/program/lib:/var/www/roundcubemail/program/include:.:/usr/share/pear:/usr/share/php') in /var/www/roundcubemail-0.3.1/plugins/password/drivers/ldap.php on line 20

2

Re: iredOS 0.6.0 roundcube ldap change password

I see that is it a problem with roundcube not finding the pear lib. But i don´t know how to fix it.

3

Re: iredOS 0.6.0 roundcube ldap change password

First, make sure you have php-pear-1.5.x or later version installed, if not, please upgrade it. You can upgrade it to php-pear-1.8.x with iRedMail yum repository, or download and install it manually here:
http://iredmail.org/yum/rpms/5/php-pear … noarch.rpm

And then, download and install Net_LDAP2:

# wget http://iredmail.org/yum/misc/Net_LDAP2-2.0.9.tgz
# pear install Net_LDAP2-2.0.9.tgz

Restart apache and you got it.