1

Topic: perl-Compress-Raw-Zlib not installed?

I am currently using iRedOS5 which have upgraded to centos5.5 and iRedMail6. Just wondering is perl-Compress-Raw-Zlib come install as default in iRedOS5/6?
I come across below thread in the chinese forum of iRedMail and notice i also have the error once time in my logwatch.

**Unmatched Entries**
    (!)Decoding of p003 (Zip archive data, at least v2.0 to extract) failed, leaving it unpacked: Compress::Raw::Zlib defines neither package nor VERSION--version check failed at (eval 103) line 467.: 1 Time(s)

http://www.iredmail.org/bbs/topic1605-iredmail060.html

I also notice I did not have perl-Compress-Raw-Zlib installed. Does it important?

[root@mail ~]# rpm -qa | grep perl-Compress
perl-Compress-Zlib-1.42-1.fc6
[root@mail ~]# yum list | grep perl-Compress
perl-Compress-Zlib.i386                  1.42-1.fc6                    installed
perl-Compress-Raw-Zlib.i386              2.015-1.el5.rf                iRedMail
[root@mail ~]# yum install perl-Compress-Raw-Zlib
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* addons: centos.maulvi.net
* base: centos.maulvi.net
* extras: centos.maulvi.net
* updates: centos.maulvi.net
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package perl-Compress-Raw-Zlib.i386 0:2.015-1.el5.rf set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package                     Arch      Version              Repository     Size
================================================================================
Installing:
perl-Compress-Raw-Zlib      i386      2.015-1.el5.rf       iRedMail      162 k

Transaction Summary
================================================================================
Install       1 Package(s)
Upgrade       0 Package(s)

Total download size: 162 k
Is this ok [y/N]:

2

Re: perl-Compress-Raw-Zlib not installed?

iRedMail installs per-Compress-Zlib by default, but not perl-Compress-Raw-Zlib.

Fixed this moment ago.

3

Re: perl-Compress-Raw-Zlib not installed?

ZhangHuangbin wrote:

iRedMail installs per-Compress-Zlib by default, but not perl-Compress-Raw-Zlib.

Fixed this moment ago.

Do iRdMail require perl-Compress-Raw-Zlib?

4

Re: perl-Compress-Raw-Zlib not installed?

perl-Compress-Raw-Zlib does not appear to report its version and thus fails.


(!)Decoding of p003 (Zip archive data, at least v2.0 to extract) failed, leaving it unpacked: Compress::Raw::Zlib defines neither package nor VERSION--version check failed at (eval 103) line 467

#rpm -qa perl-Compress-Raw-Zlib-2.015-1.el5.rf
perl-Compress-Raw-Zlib-2.015-1.el5.rf

I removed the package and reinstalled from IRedMail repo, restarted amavisd and retested resulting in the same error.

Anyone else having this error?

5

Re: perl-Compress-Raw-Zlib not installed?

Updated perl-Compress-Raw-Zlib (version: 2.030) moment ago, can you help try it?

6

Re: perl-Compress-Raw-Zlib not installed?

#rpm -qa perl-Compress-Raw-Zlib
perl-Compress-Raw-Zlib-2.030-1.el5.rf

Running the new version, still error:

(!)Decoding of p002 (Zip archive data, at least v2.0 to extract) failed, leaving it unpacked: Compress::Raw::Zlib defines neither package nor VERSION--version check failed at (eval 103) line 467

I restarted amavisd and clamd and received another interesting error but I don't think the two are related.

Starting Clam AntiVirus Daemon: WARNING: Running on 32-bit system, and RLIMIT_DATA > 2GB, lowering to 2GB!

7

Re: perl-Compress-Raw-Zlib not installed?

AFAIK wrote:

Starting Clam AntiVirus Daemon: WARNING: Running on 32-bit system, and RLIMIT_DATA > 2GB, lowering to 2GB!

Are you running a x86_64 version on i386 OS?

8

Re: perl-Compress-Raw-Zlib not installed?

ZhangHuangbin wrote:
AFAIK wrote:

Starting Clam AntiVirus Daemon: WARNING: Running on 32-bit system, and RLIMIT_DATA > 2GB, lowering to 2GB!

Are you running a x86_64 version on i386 OS?

CentOS 5 i386
Linux 2.6.18-194.17.1.el5PAE #1 SMP i686 i686 i386 GNU/Linux

9

Re: perl-Compress-Raw-Zlib not installed?

Sorry, i mean are you running ClamAV x86_64 version on i386 OS?

10 (edited by AFAIK 2010-10-08 02:02:48)

Re: perl-Compress-Raw-Zlib not installed?

ZhangHuangbin wrote:

Sorry, i mean are you running ClamAV x86_64 version on i386 OS?



clamav.i386                              0.96.3-2.el5.rf               installed
clamav-db.i386                           0.96.3-2.el5.rf               installed
clamd.i386                               0.96.3-2.el5.rf               installed

Updated:
Sep 29 14:21:42 Updated: clamd-0.96.3-2.el5.rf.i386

11

Re: perl-Compress-Raw-Zlib not installed?

Check this for the 2GB error in clamav. It seem like a bug issue

https://wwws.clamav.net/bugzilla/show_b … d=1941#c20

12

Re: perl-Compress-Raw-Zlib not installed?

Anyone know a resolution for this error? I've tried reinstalling the package but no luck.

(!)Decoding of p002 (Zip archive data, at least v2.0 to extract) failed, leaving it unpacked: Compress::Raw::Zlib defines neither package nor VERSION--version check failed at (eval 103) line 467

13

Re: perl-Compress-Raw-Zlib not installed?

Reference (1):
http://marc.info/?l=amavis-user&m=1 … 09&w=2

14

Re: perl-Compress-Raw-Zlib not installed?

OK, here's the finally solution:
http://marc.info/?l=amavis-user&m=1 … 19&w=2

perl-Compress-Zlib has been replaced with perl-IO-Compress.
Just comment-out the Compress::Raw::Zlib->VERSION(2.017) line:

--- amavisd~    2009-06-25 14:39:01.000000000 +0200
+++ amavisd    2010-10-12 11:34:40.207725223 +0200
@@ -22889,5 +22889,5 @@
   ll(4) && do_log(4, "Unzipping %s", $part->base_name);
   # avoid DoS vulnerability in < 2.017
-  Compress::Raw::Zlib->VERSION(2.017);  # required minimal version, or die
+  # Compress::Raw::Zlib->VERSION(2.017);  # module not loaded
   snmp_count('OpsDecByArZipAttempt');
   my($zip) = Archive::Zip->new;


Mark

On RHEL/CentOS, it's /usr/sbin/amavisd.
On Debian/Ubuntu, it's /usr/sbin/amavisd-new.
On FreeBSD, it's /usr/local/sbin/amavisd.

15

Re: perl-Compress-Raw-Zlib not installed?

RHEL/CentOS user can install perl-IO-Compress with yum:

# yum clean all
# yum install perl-IO-Compress

16

Re: perl-Compress-Raw-Zlib not installed?

Thanks ZhangHuangbin. The update and the patch resolved the Compress::Raw::Zlib errors.