1

Topic: Installation failing in FreeBSD-8.0 with IRedMail-0.6.1

UPDATE

This issue was fixed in the latest iRedMail development version, and will be available in iRedMail-0.8.0-beta4.
To fix it, just change 'DEBUG=NO' to '_DEBUG=NO' in conf/global.
----------


Hi,

I'm trying to install iRedHat on FreeBSD-8.0 and the installation. The software downloads ok but when installing postfix it fails with the error:

Stop in /usr/ports/mail/postfix26/work/postfix-2.6.7/src/util.
*** Error code 1

Stop in /usr/ports/mail/postfix26/work/postfix-2.6.7.
*** Error code 1

Stop in /usr/ports/mail/postfix26
*** Error code 1

Stop in /usr/ports/mail/postfix26.
<ERROR> Port was not success installed, please fix it manually and then re-execute this script.

Any ideas what is happening?

Thanks.

Eric

2

Re: Installation failing in FreeBSD-8.0 with IRedMail-0.6.1

Try this:

* When you get this error, try to Install mail/postfix26/ manually:

# cd /usr/ports/mail/postfix26/
# make clean
# make install clean

* If postfix is installed with above step, edit iRedMail-0.6.1/.iRedMail.installation.status, append this line:

export status_install_port_mailpostfix26='DONE'

* Re-execute iRedMail.sh script:

# bash iRedMail.sh

3

Re: Installation failing in FreeBSD-8.0 with IRedMail-0.6.1

Worked like a charm!!!!!!

Thanks ZhangHuangbin. Much appreciated.

Eric

4

Re: Installation failing in FreeBSD-8.0 with IRedMail-0.6.1

Hey,

My installation went well and can access my mail server from another machine on http://mydomainname/mail. However when I try to login to roundcube using the default user created during installation (www@mydomainname), the login fails.

I notice when restarting the server that slapd fails to start and from the mail log am seeing the error:
"Unable to bind to server ldap://127.0.0.1:389 as cn=vmail,dc=mydomainname, dc=com:-1 (Can't contact LDAP server)"

Advice please?

5

Re: Installation failing in FreeBSD-8.0 with IRedMail-0.6.1

ZhangHuangbin wrote:

status_install_port_mailpostfix26

Ok

After this problem, I had removed config file.
the installation try to install mysql-server but it already installed.

How can I ignore it too?

thanks

6 (edited by koma 2011-04-27 23:04:50)

Re: Installation failing in FreeBSD-8.0 with IRedMail-0.6.1

Same error in 0.7 smile

7

Re: Installation failing in FreeBSD-8.0 with IRedMail-0.6.1

koma wrote:

Same error in 0.7

Still no idea why it happened. sad

8

Re: Installation failing in FreeBSD-8.0 with IRedMail-0.6.1

I am facing the SAME problem on FreeBSD 8.2 sad sad
Anybody knows when this issue will be resolved?

9

Re: Installation failing in FreeBSD-8.0 with IRedMail-0.6.1

Here I did the above steps and it worked. Just switched to the postfix26 postfix27.

Operating system: FreeBSD 8.2

Hugs ....

10

Re: Installation failing in FreeBSD-8.0 with IRedMail-0.6.1

I did the above steps and it worked. Postfix27.

Operating system: FreeBSD 8.2
smile

11 (edited by imachine 2012-04-01 10:36:15)

Re: Installation failing in FreeBSD-8.0 with IRedMail-0.6.1

The issue persists.

It's caused by a variable DEBUG = NO appearing in postfix27/work/*/src/*/Makefile

Modify the iRedMail.sh script to not input these variables in the lines and it should be ok; I've manually removed the DEBUG = NO lines from the makefiles and it built properly.

FreeBSD 8.2, iRedMail 0.7.4

*edit*

I wonder if some configuration might be missing if I did make install clean manually and then added the proper config line to .iRedMail.installation.status