1

Topic: Hotfix for iRedAPD-1.3.1: Invalid per-user restriction of whitelist

This post is used to fix invalid per-user restriction of whitelisting sender in iRedAPD-1.3.1. if it doesn't work for you, please post a new topic in our General Technical Support forum.
========

Abstract

Whitelisting senders of per-user restrictions is not working with iRedAPD-1.3.1.

Affected versions
  • iRedAPD-1.3.1

Steps to fix it

Note: You can download and install iRedAPD-1.3.2 to avoid this issue or apply below steps to fix it on iRedAPD-1.3.1.

  • Download the new file

# cd /tmp/
# wget http://iredapd.iredmail.googlecode.com/hg/src/plugins/block_amavisd_blacklisted_senders.py?r=1.3.2 -O block_amavisd_blacklisted_senders.py
  • Replace old file

# cp /tmp/block_amavisd_blacklisted_senders.py /opt/iredapd/src/plugins/
# chmod 0555 /opt/iredapd/src/plugins/block_amavisd_blacklisted_senders.py
  • Restart iRedAPD

#
# ---- On Linux ----
#
# /etc/init.d/iredapd restart

#
# ---- On FreeBSD ----
#
# /usr/local/etc/rc.d/iredapd restart