1

Topic: iRedMail-0.9.3 has been released.

Dear all,

iRedMail-0.9.3 stable release has been released.

Below are detailed changes since iRedMail-0.9.2:

Works on new distribution releases
  • Ubuntu 15.10. [Note: 15.04 is not supported.]

  • OpenBSD 5.8. Notes:

    • OpenBSD 5.7 and earlier releases are not supported.

    • spamd(8) is not enabled and replaced by postscreen, because postscreen is better to reduce spam (e.g. with help of DNSBL services).

Removed component
Improvements
  • SOGo Groupware is now available on FreeBSD.

  • Enable HSTS (HTTP Strict Transport Security) in both Apache and Nginx.

  • Update Fail2ban filter to catch postscreen log.

  • Enable global address book for SQL backends in SOGo by default, domains are isolated. Thanks dnwahs <shawn _at_ mcsp.net> for the sharing in iRedMail forum.

  • Supports per-user alias address in SQL backends. 2 new sql columns are required: `alias.is_alias`, `alias.alias_to`.

  • Enable postscreen service in Postfix by default. If you want to enable postscreen on existing iRedMail server, please download iRedMail-0.9.3 and run the script 'tools/enable_postscreen.sh'. Important Note: all users must use port 587 for sending email, port 25 doesn't accept submitted mail by authenticated users anymore.

  • New SQL table `amavisd.outbound_wblist`, used to store whitelists and blacklists for outbound messages. It's required by iRedAPD plugin 'amavisd_wblist'.

New scripts
  • tools/ldap_assign_user_to_groups.py: Used to assign user to specified mailing lists, or remove membership.

  • tools/ldap_move_members_to_another_group.py: Used to move or copy ALL members of specified mailing list to another.

Fixed issues
  • Not add 'virusalert' in Postfix alias file.

  • Not use correct postrotate command to rotate log file on Debian.

  • Incorrectly set default fireewall zone on RHEL/CentOS 7 if you didn't choose to restart firewall immediately.

  • Incorrect Dovecot Master User account used by SOGo.

  • Dovecot Master User doesn't work with LDAP backend.

  • Incorrect quota warning priorities in Dovecot. Thanks Peter <rs _at_ samplezone.ch> for the feedback.

  • Incorrect Amavisd setting to sign DKIM on inbound messages.

  • [RHEL/CentOS] Cannot start uwsgi service with 'daemonize' setting in /etc/uwsgi.ini. ('daemonze =' is required by RHEL/CentOS v6, but not v7.)

  • Not preserve the case of ${extension} while delivering message to mailbox.

Updated packages
  • Roundcube webmail -> 1.1.3

  • uwsgi -> 2.0.11.2 (OpenBSD only)

  • iRedAPD -> 1.7.0

  • iRedAdmin -> 0.4.3

  • FreeBSD: php-5.6

2

Re: iRedMail-0.9.3 has been released.

Hi there,

gave a try on the 0.9.3, but file . ${FUNCTIONS_DIR}/policy_server.sh was not found as in the iRedMail.sh, line #106


Miles

3

Re: iRedMail-0.9.3 has been released.

miles_hc wrote:

Hi there,

gave a try on the 0.9.3, but file . ${FUNCTIONS_DIR}/policy_server.sh was not found as in the iRedMail.sh, line #106


Miles

Sorry about this trouble, i automate (part of) iRedMail testing with scripts, since this error doesn't impact the whole installation, i even didn't realize this error in terminal output.

I re-packed iRedMail-0.9.3 with this fix, please download it here:
https://bitbucket.org/zhb/iredmail/downloads

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee

4

Re: iRedMail-0.9.3 has been released.

so i'm clear, do we simply follow the upgrade steps which only has us downloading iredapd or do we also need the 0.9.3 package in some way to also update iredadmin, uwsgi, etc...? your upgrade notes only mention downloading rc mail and iredapd.

how do we go about disabling and removing cluebringer as you stated you did?

The upgrade tutorial seems in complete in this way....please advise.

5

Re: iRedMail-0.9.3 has been released.

Dear fsantiago06111979,

Our tutorial mentions how to disable Cluebringer in Postfix, but not iRedAdmin-Pro, i updated it moment ago, you can now disable Cluebringer integration in iRedAdmin-Pro by following our tutorial:
http://www.iredmail.org/docs/cluebringe … -migration

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee

6

Re: iRedMail-0.9.3 has been released.

and do i really need to download the updated 0.9.3 package?

what about updating iredadmin (free)? was this not updated as well?

thank you.

7

Re: iRedMail-0.9.3 has been released.

ok i see your cb document now. why isn't everything under one document? the original upgrade document located here:

http://www.iredmail.org/docs/upgrade.ir … 0.9.3.html

makes no mention of the cb > iredapd migration / disabling cb.

makes it all seem more confusing than it has to be.

8

Re: iRedMail-0.9.3 has been released.

fsantiago06111979 wrote:

why isn't everything under one document?

You're right. I updated the upgrade tutorial to include upgrading iRedAdmin open source edition, and migrate from cluebringer to iRedAPD:
http://www.iredmail.org/docs/upgrade.ir … 0.9.3.html

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee

9

Re: iRedMail-0.9.3 has been released.

I'm getting this on a fresh install of OpenBSD 5.8 and iRed 0.9.3

# tar jxf iRedMail-0.9.3.tar.bz2
# cd iRedMail-0.9.3
# bash iRedMail.sh
[ INFO ] Checking new version of iRedMail ...
[ INFO ] Fetching source tarballs ...
[ INFO ] + 1 of 4: http://iredmail.org/yum/misc/iRedAPD-1.7.0.tar.bz2
iRedAPD-1.7.0.tar.bz2 100% |************************************************| 58434       00:00
[ INFO ] + 2 of 4: http://iredmail.org/yum/misc/iRedAdmin-0.4.3.tar.bz2
iRedAdmin-0.4.3.tar.bz2 100% |**********************************************|   369 KB    00:01
[ INFO ] + 3 of 4: http://iredmail.org/yum/misc/roundcubem … ete.tar.gz
roundcubemail-1.1.3-co... 100% |********************************************|  4459 KB    00:06
[ INFO ] + 4 of 4: http://iredmail.org/yum/misc/uwsgi-2.0.11.2.tar.gz
uwsgi-2.0.11.2.tar.gz 100% |************************************************|   763 KB    00:02
[ INFO ] Validate packages ...  [ FAILED ]
<< ERROR >> MD5 check failed. Script exit ...

10

Re: iRedMail-0.9.3 has been released.

Dear pgatling,

I repacked iRedAPD-1.7.0, please download iRedMail-0.9.3 and try again:
https://bitbucket.org/zhb/iredmail/downloads

Sorry about this trouble.

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee

11

Re: iRedMail-0.9.3 has been released.

as installed, iredapd / cb migration scripts have file uneditable permissions:

-r-x------ 1 root root  4606 Dec 14 14:05 migrate_cluebringer_greylisting.py
-r-x------ 1 root root  4542 Dec 14 14:05 migrate_cluebringer_throttle.py

perhaps make a note of this or change the installer package.

12

Re: iRedMail-0.9.3 has been released.

ok, when I run migrate_cluebringer_throttle.py, I receive:

[root@mail tools]# python migrate_cluebringer_throttle.py
* Backend: mysql
Traceback (most recent call last):
  File "migrate_cluebringer_throttle.py", line 128, in <module>
    where='quotasid IN $quotas_ids')
  File "/usr/lib/python2.7/site-packages/web/db.py", line 682, in select
    return self.query(qout, processed=True)
  File "/usr/lib/python2.7/site-packages/web/db.py", line 644, in query
    self._db_execute(db_cursor, sql_query)
  File "/usr/lib/python2.7/site-packages/web/db.py", line 587, in _db_execute
    out = cur.execute(query, params)
  File "/usr/lib64/python2.7/site-packages/MySQLdb/cursors.py", line 174, in execute
    self.errorhandler(self, exc, value)
  File "/usr/lib64/python2.7/site-packages/MySQLdb/connections.py", line 36, in defaulterrorhandler
    raise errorclass, errorvalue
_mysql_exceptions.ProgrammingError: (1064, "You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ')' at line 1")
[root@mail tools]#


so now what?

13

Re: iRedMail-0.9.3 has been released.

Could you please open migrate_cluebringer_throttle.py, find line below:

web.config.debug = debug

Then change it to:

web.config.debug = True

Then run migrate_cluebringer_throttle.py again. It will print some debug message on terminal, we need them for troubleshooting.

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee

14

Re: iRedMail-0.9.3 has been released.

root@mail tools]# python migrate_cluebringer_throttle.py
* Backend: mysql
0.0 (1): SELECT id, name, period FROM quotas WHERE name IN ('default_inbound', 'default_outbound') AND disabled=0
0.0 (2): SELECT id, name, period FROM quotas WHERE (name LIKE 'inbound_%' OR name LIKE 'outbound_%') AND disabled=0
ERR: SELECT quotasid, type, counterlimit FROM quotas_limits WHERE quotasid IN ()
Traceback (most recent call last):
  File "migrate_cluebringer_throttle.py", line 128, in <module>
    where='quotasid IN $quotas_ids')
  File "/usr/lib/python2.7/site-packages/web/db.py", line 682, in select
    return self.query(qout, processed=True)
  File "/usr/lib/python2.7/site-packages/web/db.py", line 644, in query
    self._db_execute(db_cursor, sql_query)
  File "/usr/lib/python2.7/site-packages/web/db.py", line 587, in _db_execute
    out = cur.execute(query, params)
  File "/usr/lib64/python2.7/site-packages/MySQLdb/cursors.py", line 174, in execute
    self.errorhandler(self, exc, value)
  File "/usr/lib64/python2.7/site-packages/MySQLdb/connections.py", line 36, in defaulterrorhandler
    raise errorclass, errorvalue
_mysql_exceptions.ProgrammingError: (1064, "You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ')' at line 1")
[root@mail tools]#

15

Re: iRedMail-0.9.3 has been released.

Hi

According to the SQL command, you don't have any throttle settings in Cluebringer database. So it's ok not to run this script (no data need to be migrated).

And here's patch to fix this error:

diff -r 6b1aa02e6c3e tools/migrate_cluebringer_throttle.py
--- a/tools/migrate_cluebringer_throttle.py    Mon Dec 14 22:14:45 2015 +0800
+++ b/tools/migrate_cluebringer_throttle.py    Tue Dec 15 08:37:08 2015 +0800
@@ -121,6 +121,9 @@
                            'period': _period,
                            'priority': priority}
 
+if not quotas_ids:
+    sys.exit('No throttle settings found. Exit.')
+
 # Get detailed throttle settings.
 qr = conn.select('quotas_limits',
                  vars={'quotas_ids': quotas_ids},

Or, download this patched file and replace /opt/iredapd/tools/migrate_cluebringer_throttle.py on your server:
https://bitbucket.org/zhb/iredapd/raw/d … hrottle.py

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee

16

Re: iRedMail-0.9.3 has been released.

Thanks, all fixed.

found another thing; in your guide:

2: Redirect /.well-known/carddav access to SOGo

Find below line in default.conf:

rewrite ^/.well-known/caldav    /SOGo/dav permanent;

Add a new line right after above line:

rewrite ^/.well-known/caldav    /SOGo/dav permanent;
rewrite ^/.well-known/carddav   /SOGo/dav permanent;

Restarting Nginx service is required.

those rewrite lines don't exist in my nginx config. ??????

17

Re: iRedMail-0.9.3 has been released.

fsantiago06111979 wrote:

those rewrite lines don't exist in my nginx config. ??????

Please add both.

== UPDATE ==

Fixed this improper description in upgrade tutorial.

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee

18

Re: iRedMail-0.9.3 has been released.

should they be added under the http or https block or both?

19

Re: iRedMail-0.9.3 has been released.

ha, nevermind, read your update.

20

Re: iRedMail-0.9.3 has been released.

ok all done, anything else i should be aware of as of now?

21 (edited by kenichi64 2015-12-15 22:43:10)

Re: iRedMail-0.9.3 has been released.

Hi..
FYI
iRedAPD -> 1.7.0 can't install on Debian 8.2

upgrade_iredapd.sh: 37: [: XLINUX: unexpected operator
upgrade_iredapd.sh: 72: [: XLINUX: unexpected operator
upgrade_iredapd.sh: 81: [: XLINUX: unexpected operator
Cannot detect Linux/BSD distribution. Exit.
Please contact author iRedMail team <support@iredmail.org> to solve it.


iRedAdmin -> 0.4.3
Same Error Cannot detect Linux/BSD distribution. Exit.

No LSB modules are available.
Distributor ID:    Debian
Description:    Debian GNU/Linux 8.2 (jessie)
Release:    8.2
Codename:    jessie

uname -a
SMP Debian 3.16.7-ckt11-1+deb8u6 (2015-11-09) i686 GNU/Linux

thank you

22

Re: iRedMail-0.9.3 has been released.

fsantiago06111979 wrote:

ok all done, anything else i should be aware of as of now?

Should be fine.

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee

23

Re: iRedMail-0.9.3 has been released.

kenichi64 wrote:

iRedAPD -> 1.7.0 can't install on Debian 8.2
upgrade_iredapd.sh: 37: [: XLINUX: unexpected operator
upgrade_iredapd.sh: 72: [: XLINUX: unexpected operator
upgrade_iredapd.sh: 81: [: XLINUX: unexpected operator

Please run the script with 'bash':

bash upgrade_iredapd.sh

Different shells have different syntax.

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee

24

Re: iRedMail-0.9.3 has been released.

When you enable greylisting in iredapd, don't you need to add greylisting to the settings config value in settings.py or else iredapd won't use that plugin?

25

Re: iRedMail-0.9.3 has been released.

Thanks, ZHB, for all of your hard work!