1

Topic: iRedMail-0.7.2 released.

Dear all,

iRedMail-0.7.2 is now available for production use. v0.7.2 is a bug fix release, it also fixes some possible XSS vulnerabilities in iRedAdmin (open source edition).

Below are changes since v0.7.1:

  • It now works on Ubuntu 11.04.

  • Enable LDAPS on FreeBSD by default. Thanks Markus Wyrsch <W-Chi@>.

  • Add alias domain support in postfix virtual_mailbox_domains (MySQL backend special).

  • Set 'ServerTokens' to 'ProductOnly' in Apache on Debian/Ubuntu. Thanks c33s@forum.

  • Update Fail2ban filter to catch more password failures in Postfix log file.

  • Package update:

    • Roundcube webmail -> 0.5.3

    • phpLDAPadmin -> 1.2.1.1

    • phpMyAdmin -> 3.4.1

    • iRedAPD -> 1.3.6. Fixes two issues which are MySQL backend special.

    • iRedAdmin -> 0.1.5. Fixes some possible XSS vulnerabilities.


Links:

Some addition tutorials you might be interested in:

2

Re: iRedMail-0.7.2 released.

Greetings,

The 0.7.2 update seems to update phpMyAdmin, however the article about upgrading from 0.7.1 to 0.7.2 mentions nothing about installing the new version.

Can you clarify the proper steps to install the new version?

Thanks

3

Re: iRedMail-0.7.2 released.

thanks for the upgrade instructions. no errors (ubuntu 10.04)

the phpmyadmin module is installed via the package manager (on my ubuntu 10.04). so the new version is probably distribtution specific?

the roundcube webmail 0.5.3 is included in the new version but since this is my first upgrade i'm not sure if there are upgrade instructions or if i just follow the instructions at roundcube.net?

thanks!

4

Re: iRedMail-0.7.2 released.

@bp1: phpMyAdmin doesn't require special setting for upgrading, simply download a new version, move it to Apache server root, and it works.

@wm: Just follow the instruction at roundcube.net. Also, here's a reference:
http://iredmail.org/wiki/index.php?titl … e_to_0.3.1

5

Re: iRedMail-0.7.2 released.

hello, i got an error when i tried to install this version (0.7.2) on debian 6 amd 64 version
Error: Your Os is not supported yet
are sure that debian 6 is supported??

6

Re: iRedMail-0.7.2 released.

Hello all !

To update iredmail, i only have to change some conf lines mentionned in this page ?
Or must I run install.sh wich is in the tar.bz2 ?

Thanks

7

Re: iRedMail-0.7.2 released.

nicolasfo wrote:

To update iredmail, i only have to change some conf lines mentionned in this page ?

Yes.

8

Re: iRedMail-0.7.2 released.

No software (like roundcube) needed ?

9

Re: iRedMail-0.7.2 released.

nicolasfo wrote:

No software (like roundcube) needed ?

Some addition components can be upgraded optionally. e.g. Roundcube, phpMyAdmin, phpLDAPadmin.

10

Re: iRedMail-0.7.2 released.

serval21 wrote:

hello, i got an error when i tried to install this version (0.7.2) on debian 6 amd 64 version
Error: Your Os is not supported yet
are sure that debian 6 is supported??

I've also tried with a 32 bits debian version, but it's the same problem!! is there any iredmail developper ??

11

Re: iRedMail-0.7.2 released.

serval21 wrote:

I've also tried with a 32 bits debian version, but it's the same problem!! is there any iredmail developper ??

How did you execute script 'iRedMail.sh'? You must execute with bash, not 'sh':

# cd /path/to/iRedMail-0.7.2/
# bash iRedMail.sh