1

Topic: Postfix/qmgr unable to connect to transport private with postfixadmin

Hey,

in the tutorial http://www.iredmail.org/wiki/index.php? … QL.Backend is either a huge error or something has changed majorly with 2.3.3 of postfixadmin.
if you create a new mailbox, mailbox.transport is set with a space and not with "dovecot" or something like that. Due to this misconfiguration postfix is not able to deliver mails to the mailboxes. I had to manually edit all the mailboxes and add "dovecot" to mailbox.transport (ofc without the quotes).
Any info on how to fix this in postfixadmin? I don't want to add this detail each time a add a mailbox.

Just took me 3 hours to figure out. search on the completely wrong end (postfix).

greetings,
sven

2

Re: Postfix/qmgr unable to connect to transport private with postfixadmin

Default SQL structure is slightly changed. In vmail.mailbox, transport is set to '' (empty, not a SPACE character) by default.

CREATE TABLE IF NOT EXISTS mailbox (
    [...]
    transport VARCHAR(255) NOT NULL DEFAULT '',
    [...]

You can simply change postfix lookup file: /etc/postfix/mysql/transport_maps_user.cf, append AND transport<>'' in query.

In iRedMail-0.7.0, it's set to:

query       = SELECT mailbox.transport FROM mailbox,domain WHERE mailbox.username='%s' AND mailbox.domain='%d' AND mailbox.domain=domain.domain AND mailbox.transport<>'' AND mailbox.active=1 AND mailbox.enabledeliver=1 AND domain.backupmx=0 AND domain.active=1

3

Re: Postfix/qmgr unable to connect to transport private with postfixadmin

I updated wiki tutorial here:
http://www.iredmail.org/wiki/index.php? … tant_Notes

Mentions this change. Thanks for your reminder. smile

4

Re: Postfix/qmgr unable to connect to transport private with postfixadmin

I'm using a fresh install of iRedMail 0.7.0 and your described settings are all set to these (by default).
Still, if I create a new mailbox via PostfixAdmin the transport-field is empty and postfix can't find the according transport-destination.