1

Topic: apt-get/aptitude

Silly question, but is it safe to update things like dovecot, postfix, etc?

2

Re: apt-get/aptitude

Yes. Update packages via yum/apt/ports tree are the only way to update binary packages.

3

Re: apt-get/aptitude

ZhangHuangbin wrote:

Yes. Update packages via yum/apt/ports tree are the only way to update binary packages.

That is true. But with a solution like iredmail, you have to be careful not to destroy the current running config.
I was running into a problem at some point with Debian 5, when openLDAP was updated to the latest version, which broke the whole LDAP setup.

So yes, you should do updates with OS package manager, but be very careful.

4

Re: apt-get/aptitude

Awesome. Thanks for the info.

5

Re: apt-get/aptitude

derchris wrote:

So yes, you should do updates with OS package manager, but be very careful.

Could you give some details on the ldap upgrade issue in Debian?

I am in the middle of some ldap issues, and wonder if you ran in to the same thing.

6

Re: apt-get/aptitude

robfantini wrote:
derchris wrote:

So yes, you should do updates with OS package manager, but be very careful.

Could you give some details on the ldap upgrade issue in Debian?

I am in the middle of some ldap issues, and wonder if you ran in to the same thing.

All I rememebr was that the LDAP layout has been changed with some update, and I was no longer able to import/use the iRedMail LDAP schemes.
And because of my setup at that time, was not able to re-install older LDAP version.
So had to re-install whole server from scratch.

7 (edited by robfantini 2011-03-06 23:32:32)

Re: apt-get/aptitude

derchris wrote:

All I rememebr was that the LDAP layout has been changed with some update, and I was no longer able to import/use the iRedMail LDAP schemes.
And because of my setup at that time, was not able to re-install older LDAP version.
So had to re-install whole server from scratch.


Could you tell me which  distribution and version ended up working for you?

Also which version of iRedMail ?

8

Re: apt-get/aptitude

At the moment I'm using the latest beta on Deb6

9

Re: apt-get/aptitude

derchris wrote:

At the moment I'm using the latest beta on Deb6

do you use ldap for other than mail users?

10

Re: apt-get/aptitude

robfantini wrote:
derchris wrote:

At the moment I'm using the latest beta on Deb6

do you use ldap for other than mail users?

no