1

Topic: Upgraded to PHP5.3 broken RoundCube

Hi, I upgrade the PHP version on the server last night on my Debain Lenny server using apt-get.

Now when I try to login via RoundCube I get the following error:
DB Error in /usr/share/apache2/roundcubemail-0.3.1/program/include/rcube_mdb2.php (627): MDB2 Error: unknown error Query: _execute: [Error message: Unable to execute statement] [Last executed query: DELETE FROM session WHERE sess_id=?] [Native code: 0]
Warning: Cannot modify header information - headers already sent in /usr/share/apache2/roundcubemail-0.3.1/program/include/rcmail.php on line 1066 DB Error in /usr/share/apache2/roundcubemail-0.3.1/program/include/rcube_mdb2.php (627): MDB2 Error: unknown error Query: _execute: [Error message: Unable to execute statement] [Last executed query: UPDATE users SET last_login=now() WHERE user_id=?] [Native code: 0]
DB Error in /usr/share/apache2/roundcubemail-0.3.1/program/include/rcube_mdb2.php (627): MDB2 Error: unknown error Query: _execute: [Error message: Unable to execute statement] [Last executed query: DELETE FROM session WHERE sess_id=?] [Native code: 0]
Warning: Cannot modify header information - headers already sent in /usr/share/apache2/roundcubemail-0.3.1/program/include/rcmail.php on line 1066 Warning: Cannot modify header information - headers already sent in /usr/share/apache2/roundcubemail-0.3.1/program/include/rcube_template.php on line 276 DB Error in /usr/share/apache2/roundcubemail-0.3.1/program/include/rcube_mdb2.php (627): MDB2 Error: unknown error Query: _execute: [Error message: Unable to execute statement] [Last executed query: INSERT INTO session (sess_id, vars, ip, created, changed) VALUES (?, ?, ?, FROM_UNIXTIME(1299235419), FROM_UNIXTIME(1299235419))] [Native code: 0]


I fixed the first error with the time zone not being set in the php.ini file althoug now I dont know what else to check.

Thanks

2

Re: Upgraded to PHP5.3 broken RoundCube

I see you have roundcube 0.3.1, upgrade it to 0.5.1.

3

Re: Upgraded to PHP5.3 broken RoundCube

maxie_ro wrote:

I see you have roundcube 0.3.1, upgrade it to 0.5.1.

That fixed it thanks. I should of thought of that first.