1

Topic: Domain alias not working with alias or catch-all

We tried to send an e-mail to an alias account, when using the normal domain it works, but when mailing to the domain alias it is refused because the user does not exist in the virtual mailbox table

2

Re: Domain alias not working with alias or catch-all

Which version of iRedMail do you use? Have all upgrade tutorials applied?

3 (edited by veldsink 2011-02-18 16:35:29)

Re: Domain alias not working with alias or catch-all

We are using iRedMail 0.6.0.

For as far as I know all upgrade tutorials have been followed

I don't see the option for the domain alias in the ldap, only for users.

4

Re: Domain alias not working with alias or catch-all

Did you apply this?
http://www.iredmail.org/forum/topic1023 … -work.html

It's part of hotfixes for 0.6.0:
http://www.iredmail.org/wiki/index.php? … tfix/0.6.0

5

Re: Domain alias not working with alias or catch-all

This hotfix has been applied, the problem is that with aliasses the domain alliasses aren't added as a shadow address in ldap.

6

Re: Domain alias not working with alias or catch-all

veldsink wrote:

the problem is that with aliasses the domain alliasses aren't added as a shadow address in ldap.

Do you mean you add a alias domain in domain profile page, but users don't have "shadowAddress=user@new_domain"?

7

Re: Domain alias not working with alias or catch-all

ZhangHuangbin wrote:
veldsink wrote:

the problem is that with aliasses the domain alliasses aren't added as a shadow address in ldap.

Do you mean you add a alias domain in domain profile page, but users don't have "shadowAddress=user@new_domain"?

Here is an ldif export from an alias:

dn: mail=[deleted],ou=Aliases,domainName=[deleted],o=domains,dc=[deleted],dc=[deleted]
accountStatus: active
cn: test
enabledService: mail
enabledService: deliver
mail: [deleted]
mailForwardingAddress: [deleted]
objectClass: mailAlias

8

Re: Domain alias not working with alias or catch-all

Any ideas?

9

Re: Domain alias not working with alias or catch-all

Do you mean miss "shadowAddress=alias@[alias_domain.com]" in alias account?

If so, it's not achieved in iRedAdmin-Pro yet, will implement it in next release.

10

Re: Domain alias not working with alias or catch-all

ZhangHuangbin wrote:

Do you mean miss "shadowAddress=alias@[alias_domain.com]" in alias account?

If so, it's not achieved in iRedAdmin-Pro yet, will implement it in next release.

Can it also be achieved for the catch-all account? like "@[alias_domain.com]".

11

Re: Domain alias not working with alias or catch-all

veldsink wrote:

Can it also be achieved for the catch-all account? like "@[alias_domain.com]".

Will try to achieve it too. Thanks for your reminder. smile