1

Topic: Installation problems

Hey, I'm having some problems with installing iRedMail (0.6.0-RC1). At first it had a problem with the MySQL database version. It needed 5.0 but i had 5.1 installed. So i changed the version in functions/packages.sh (as advised by iredmail support) to 5.1. After that, the installation proceeded without any problems, until this:

Setting up postfix-policyd (1.82-2ubuntu1) ...
dbconfig-common: writing config to /etc/dbconfig-common/postfix-policyd.conf
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO).
unable to connect to mysql server.
error encountered creating user:
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
dbconfig-common: postfix-policyd configure: aborted.
dbconfig-common: flushing administrative password
dpkg: error processing postfix-policyd (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
postfix-policyd
E: Sub-process /usr/bin/dpkg returned an error code (1)
< ERROR > Installation failed, please check the terminal output.


For some reason it's not using the mysql password i typed in during the configuration. Any ideas? Perhaps this has something to do with me changing the version from 5.0 to 5.1?

As for the version i'm using, here's the output of "uname -a":
Linux UBUNTU-PGM 2.6.31-20-server #58-Ubuntu SMP Fri Mar 12 05:40:05 UTC 2010 x86_64 GNU/Linux

(It's Ubuntu 9.10)

2

Re: Installation problems

what is your apt source list?

3

Re: Installation problems

Same error here.

Ubuntu 9.10

Mysql modified from 5.0 to 5.1

Sources.list

#
# deb cdrom:[Ubuntu-Server 9.10 _Karmic Koala_ - Release i386 (20091027.2)]/ karmic main restricted

#deb cdrom:[Ubuntu-Server 9.10 _Karmic Koala_ - Release i386 (20091027.2)]/ karmic main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://it.archive.ubuntu.com/ubuntu/ karmic main restricted
deb-src http://it.archive.ubuntu.com/ubuntu/ karmic main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://it.archive.ubuntu.com/ubuntu/ karmic-updates main restricted
deb-src http://it.archive.ubuntu.com/ubuntu/ karmic-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://it.archive.ubuntu.com/ubuntu/ karmic universe
deb-src http://it.archive.ubuntu.com/ubuntu/ karmic universe
deb http://it.archive.ubuntu.com/ubuntu/ karmic-updates universe
deb-src http://it.archive.ubuntu.com/ubuntu/ karmic-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://it.archive.ubuntu.com/ubuntu/ karmic multiverse
deb-src http://it.archive.ubuntu.com/ubuntu/ karmic multiverse
deb http://it.archive.ubuntu.com/ubuntu/ karmic-updates multiverse
deb-src http://it.archive.ubuntu.com/ubuntu/ karmic-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://it.archive.ubuntu.com/ubuntu/ karmic-backports main restricted universe multiverse
# deb-src http://it.archive.ubuntu.com/ubuntu/ karmic-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu karmic partner
# deb-src http://archive.canonical.com/ubuntu karmic partner

deb http://security.ubuntu.com/ubuntu karmic-security main restricted
deb-src http://security.ubuntu.com/ubuntu karmic-security main restricted
deb http://security.ubuntu.com/ubuntu karmic-security universe
deb-src http://security.ubuntu.com/ubuntu karmic-security universe
deb http://security.ubuntu.com/ubuntu karmic-security multiverse
deb-src http://security.ubuntu.com/ubuntu karmic-security multiverse

4

Re: Installation problems

The default one that comes with ubuntu. Haven't changed much, just added a source for  bijk.com and that's it. I have the universe and the multiverse deposits added. And yes, i have done a "apt-get update" command smile

Any suggestions?

5

Re: Installation problems

Nowhere in the installation process it says that the instalation will screw up your system. It took me a lot of time to set up and configure the server and the ldap database.... which is now gone. God fu***** damn it. If you have anything of value on the system, dont install this hmm No srsly.... it flushed my database completley.

The way i got over that mysql problem is this:
I created a new mysql user with all privileges and eddited the file "/etc/dbconfig-common/postfix-policyd.conf" and changed "dbc_dbadmin" to that user. Then it worked smile

6

Re: Installation problems

pretty much the first line of the Ubuntu (and all other distro's) installation tutornial says the following

***************************** WARNING ********************************
* iRedMail is designed to deploy on a FRESH server system, otherwise *
* it may override your existing files/configurations althought it    *
* will backup files before modify.                                   *
***************************** WARNING ********************************

7

Re: Installation problems

So where is my LDAP backup? Well, no matter, it took me so long becouse i was figuring out how to do it, it shouldnt take nearly as long now smile This first server system was a test aniway, just to test everything out, when we do the final server we will be more carefull. Hmm, so if it's supposed to be installed on a fresh server system, should we install it before doing anything else?

8

Re: Installation problems

suggest you install a fresh system and install iRedMail.

9 (edited by Squeazer 2010-04-24 17:54:17)

Re: Installation problems

Will do. Oh, does anyone know why iRedMail wants to install phpmyadmin 2.11.10 when 3.3.2 is already out?  And it seems like they're using a lot of outdated stuff:

LibClamAV Warning: ***********************************************************
LibClamAV Warning: ***  This version of the ClamAV engine is outdated.     ***
LibClamAV Warning: *** DON'T PANIC! Read http://www.clamav.net/support/faq ***
LibClamAV Warning: ***********************************************************

Oh and if you want to use phpLDAPadmin directly from the installation, you need to edit /etc/apache2/conf.d/phpldapadmin.conf un-comment the Alias mapps, otherwise it wont work. This is not iRedMail-s fault, i've seen this with "standalone" phpldapadmin installations. This, however, wont work if you have the default ssl site enabled (which is by default with the iRedMail installation). Than you have to add the Alias line to your virtual host apache2/sites-available/default

10 (edited by Squeazer 2010-04-24 18:01:04)

Re: Installation problems

Hey, I'm having a nother problem when installing iredmail, on a fresh system this time. I installed it succesfully on my local vmware machine, but when i try to do it on the remote machine (HYPER-V, Ubuntu 9.10) i get this error:

(Reading database ... 46650 files and directories currently installed.)
Unpacking mysql-server-5.0 (from .../mysql-server-5.0_5.1.30really5.0.83-0ubuntu3_amd64.deb) ...
Aborting downgrade from (at least) 5.1 to 5.0.
dpkg: error processing /var/cache/apt/archives/mysql-server-5.0_5.1.30really5.0.83-0ubuntu3_amd64.deb (--unpack):
subprocess new pre-installation script returned error exit status 1
Errors were encountered while processing:
/var/cache/apt/archives/mysql-server-5.0_5.1.30really5.0.83-0ubuntu3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
< ERROR > Installation failed, please check the terminal output.

Any ideas?

11

Re: Installation problems

you can run

apt-get clean

and install again.

12

Re: Installation problems

No good, still get the error:
After this operation, 81.7MB of additional disk space will be used.
Get:1 http://si.archive.ubuntu.com karmic/universe mysql-server-5.0 5.1.30really5.0.83-0ubuntu3 [24.2MB]
Fetched 24.2MB in 22s (1092kB/s)
Preconfiguring packages ...
(Reading database ... 46650 files and directories currently installed.)
Unpacking mysql-server-5.0 (from .../mysql-server-5.0_5.1.30really5.0.83-0ubuntu3_amd64.deb) ...
Aborting downgrade from (at least) 5.1 to 5.0.
dpkg: error processing /var/cache/apt/archives/mysql-server-5.0_5.1.30really5.0.83-0ubuntu3_amd64.deb (--unpack):
subprocess new pre-installation script returned error exit status 1
Errors were encountered while processing:
/var/cache/apt/archives/mysql-server-5.0_5.1.30really5.0.83-0ubuntu3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
< ERROR > Installation failed, please check the terminal output.

Should i install mysql manually? Would that do it?

13

Re: Installation problems

Can you please try to delete mysql-server and mysql-client before installing iRedMail?

14

Re: Installation problems

Hmm, for some reason, at OS installation, the LAMP packages got installed. I'll remove any traces of it and try again.

15

Re: Installation problems

installation not completed in Open SuSe 11.3.

< INFO > Checking necessary command/package: dialog/dialog ...
< INFO > Check configuration file: /home/admin/Downloads/iRedMail-0.6.1/./config...    Found.
< Question > Use it for mail server setting? [y|N]y
< INFO > Use configuration file: /home/admin/Downloads/iRedMail-0.6.1/./config for mail server setting.
< INFO > Import installation process status from file: /home/admin/Downloads/iRedMail-0.6.1/./.iRedMail.installation.status.
< INFO > Installing package(s):
Too few arguments.
At least one package name is required.
install (in) [options] <capability|rpm_file_uri> ...

Install packages with specified capabilities or RPM files with specified
location. A capability is NAME[.ARCH][OP<VERSION>], where OP is one
of <, <=, =, >=, >.

  Command options:
    --from <alias|#|URI>    Select packages from the specified repository.
-r, --repo <alias|#|URI>    Load only the specified repository.
-t, --type <type>           Type of package (package, patch, pattern, product, srcpackage).
                            Default: package.
-n, --name                  Select packages by plain name, not by capability.
-C, --capability            Select packages by capability.
-f, --force                 Reinstall the package if the exact version is
                            available in repositories.
-l, --auto-agree-with-licenses
                            Automatically say 'yes' to third party license
                            confirmation prompt.
                            See 'man zypper' for more details.
    --debug-solver          Create solver test case for debugging.
    --no-recommends         Do not install recommended packages, only required.
    --recommends            Install also recommended packages in addition
                            to the required.
-R, --no-force-resolution   Do not force the solver to find solution,
                            let it ask.
    --force-resolution      Force the solver to find a solution (even
                            an aggressive one).
-D, --dry-run               Test the installation, do not actually install.
    --download              Set the download-install mode. Available modes:
                            only, in-advance, in-heaps, as-needed
-d, --download-only         Only download the packages, do not install.

< ERROR > Installation failed, please check the terminal output.

How to Solve this issue?

16

Re: Installation problems

Samy wrote:

< INFO > Installing package(s):
Too few arguments.
At least one package name is required.

You didn't config iRedMail via dialog wizard. When it ask you below question, please answer 'n' to start config wizard.

Samy wrote:

< INFO > Check configuration file: /home/admin/Downloads/iRedMail-0.6.1/./config...    Found.
< Question > Use it for mail server setting? [y|N]

Also, please create new forum topic for new questions.