1 (edited by keliweb 2010-12-09 20:40:30)

Topic: Problem Mail

Hello,
I have buy PRO version of your control panel and I am configuring the email server.
8 domain will be hosted on this server.
doing the test I found that not all can receive email and SMTP logs I see this error:

wizone.it the domain was added from the Control Panel


Dec  9 12:16:46 mailserver postfix/smtpd[3001]: connect from unknown[89.119.233.4]
Dec  9 12:16:47 mailserver postfix/smtpd[3001]: NOQUEUE: reject: RCPT from unknown[89.119.233.4]: 553 5.7.1 <g.lepore@finedit.com>: Sender address rejected: not logged in; from=<g.lepore@finedit.com> to=<info@wizone.it> proto=ESMTP helo=<mail.quotidianosera.it>
Dec  9 12:16:47 mailserver postfix/smtpd[3001]: disconnect from unknown[89.119.233.4]


This is my configuration file for postfix:

[root@mailserver ~]# postconf -n
alias_database = hash:/etc/postfix/aliases
alias_maps = hash:/etc/postfix/aliases
allow_min_user = no
biff = no
bounce_queue_lifetime = 1d
broken_sasl_auth_clients = yes
command_directory = /usr/sbin
config_directory = /etc/postfix
content_filter = smtp-amavis:[127.0.0.1]:10024
daemon_directory = /usr/libexec/postfix
data_directory = /var/lib/postfix
debug_peer_level = 2
delay_warning_time = 0h
disable_vrfy_command = yes
enable_original_recipient = no
home_mailbox = Maildir/
html_directory = no
inet_interfaces = all
inet_protocols = ipv4
mail_name = iRedMail
mail_owner = postfix
mail_version = 0.6.1
mailbox_command = /usr/libexec/dovecot/deliver
mailbox_size_limit = 15728640
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man
maximal_backoff_time = 4000s
maximal_queue_lifetime = 1d
minimal_backoff_time = 300s
mydestination = $myhostname, localhost, localhost.localdomain, localhost.$myhostname
mydomain = ilquotidianoweb.it
myhostname = mailserver.ilquotidianoweb.it
mynetworks = 127.0.0.0/8
mynetworks_style = subnet
myorigin = mailserver.ilquotidianoweb.it
newaliases_path = /usr/bin/newaliases.postfix
proxy_read_maps = $canonical_maps $lmtp_generic_maps $local_recipient_maps $mydestination $mynetworks $recipient_bcc_maps $recipient_canonical_maps $relay_domains $relay_recipient_maps $relocated_maps $sender_bcc_maps $sender_canonical_maps $smtp_generic_maps $smtpd_sender_login_maps $transport_maps $virtual_alias_domains $virtual_alias_maps $virtual_mailbox_domains $virtual_mailbox_maps
queue_directory = /var/spool/postfix
queue_run_delay = 300s
readme_directory = /usr/share/doc/postfix-2.5.9/README_FILES
recipient_bcc_maps = proxy:ldap:/etc/postfix/ldap_recipient_bcc_maps_domain.cf, proxy:ldap:/etc/postfix/ldap_recipient_bcc_maps_user.cf
recipient_delimiter = +
relay_domains = $mydestination, proxy:ldap:/etc/postfix/ldap_relay_domains.cf
relay_recipient_maps = proxy:ldap:/etc/postfix/ldap_virtual_mailbox_maps.cf
sample_directory = /usr/share/doc/postfix-2.5.9/samples
sender_bcc_maps = proxy:ldap:/etc/postfix/ldap_sender_bcc_maps_domain.cf, proxy:ldap:/etc/postfix/ldap_sender_bcc_maps_user.cf
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
smtpd_data_restrictions = reject_unauth_pipelining
smtpd_enforce_tls = no
smtpd_helo_required = yes
smtpd_helo_restrictions = permit_mynetworks,permit_sasl_authenticated, check_helo_access pcre:/etc/postfix/helo_access.pcre
smtpd_recipient_restrictions = reject_unknown_sender_domain, reject_unknown_recipient_domain, reject_non_fqdn_sender, reject_non_fqdn_recipient, reject_unlisted_recipient, check_policy_service inet:127.0.0.1:7777, permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination, reject_non_fqdn_helo_hostname, reject_invalid_helo_hostname, check_policy_service inet:127.0.0.1:10031
smtpd_reject_unlisted_recipient = yes
smtpd_reject_unlisted_sender = yes
smtpd_sasl_auth_enable = yes
smtpd_sasl_authenticated_header = no
smtpd_sasl_local_domain =
smtpd_sasl_path = dovecot-auth
smtpd_sasl_security_options = noanonymous
smtpd_sasl_type = dovecot
smtpd_sender_login_maps = proxy:ldap:/etc/postfix/ldap_sender_login_maps.cf
smtpd_sender_restrictions = check_policy_service inet:127.0.0.1:7778, permit_mynetworks, reject_sender_login_mismatch, permit_sasl_authenticated
smtpd_tls_cert_file = /etc/pki/tls/certs/iRedMail_CA.pem
smtpd_tls_key_file = /etc/pki/tls/private/iRedMail.key
smtpd_tls_loglevel = 0
smtpd_tls_security_level = may
tls_random_source = dev:/dev/urandom
transport_maps = proxy:ldap:/etc/postfix/ldap_transport_maps_user.cf, proxy:ldap:/etc/postfix/ldap_transport_maps_domain.cf
unknown_local_recipient_reject_code = 550
virtual_alias_maps = proxy:ldap:/etc/postfix/ldap_virtual_alias_maps.cf, proxy:ldap:/etc/postfix/ldap_virtual_group_maps.cf, proxy:ldap:/etc/postfix/ldap_sender_login_maps.cf, proxy:ldap:/etc/postfix/ldap_catch_all_maps.cf
virtual_gid_maps = static:500
virtual_mailbox_base = /var/vmail
virtual_mailbox_domains = proxy:ldap:/etc/postfix/ldap_virtual_mailbox_domains.cf
virtual_mailbox_maps = proxy:ldap:/etc/postfix/ldap_virtual_mailbox_maps.cf
virtual_minimum_uid = 500
virtual_transport = dovecot
virtual_uid_maps = static:500


you can help me solve the problem?

Regards

Paolo Pellicori

2

Re: Problem Mail

<g.lepore@finedit.com>: Sender address rejected: not logged in;

It's clear. You should config your mail client to enable SMTP auth for sending mail.

3 (edited by keliweb 2010-12-09 21:10:49)

Re: Problem Mail

hello,
emails are sent to another SMTP server  ( and the SMTP server that will be used for domains on this server will be outside the email server itself )

by sending from gmail have this error:

Dec  9 13:47:56 mailserver postfix/smtpd[3684]: NOQUEUE: reject: RCPT from unknown[209.85.216.171]: 450 4.7.1 <info@wizone.it>: Recipient address rejected: Policy Rejection- Please try later.; from=<pellicori.paolo@gmail.com> to=<info@wizone.it> proto=ESMTP helo=<mail-qy0-f171.google.com>
Dec  9 13:47:56 mailserver postfix/smtpd[3684]: disconnect from unknown[209.85.216.171]


other test send email to libero.it
Dec  9 14:09:35 mailserver postfix/smtpd[3794]: NOQUEUE: reject: RCPT from unknown[212.52.84.103]: 450 4.7.1 <info@wizone.it>: Recipient address rejected: Policy Rejection- Please try later.; from=<dicemans82@libero.it> to=<info@wizone.it> proto=ESMTP helo=<cp-out3.libero.it>
Dec  9 14:09:35 mailserver postfix/smtpd[3794]: disconnect from unknown[212.52.84.103]

4

Re: Problem Mail

update:
after 10 minutes of sending the emails sent back if they sell are accepted by SMTP sender with a greylist = update


Dec  9 14:29:12 mailserver postfix/smtpd[3950]: connect from unknown[212.52.84.104]
Dec  9 13:29:12 mailserver policyd: connection from: 127.0.0.1 port: 39654 slots: 0 of 2044 used
Dec  9 13:29:12 mailserver policyd: rcpt=18, greylist=update, host=212.52.84.104 (unknown), from=dicemans82@libero.it, to=info@wizone.it, size=605
Dec  9 13:29:12 mailserver policyd: rcpt=18, throttle_rcpt=update(a), host=212.52.84.104, from=dicemans82@libero.it, to=info@wizone.it, count=7/64(8), threshold=9%
Dec  9 14:29:12 mailserver postfix/smtpd[3950]: 5689137F81F9: client=unknown[212.52.84.104]
Dec  9 14:29:12 mailserver postfix/cleanup[3954]: 5689137F81F9: message-id=<18089172.1743461291901318921.JavaMail.root@wmail10.libero.it>
Dec  9 14:29:12 mailserver postfix/qmgr[3562]: 5689137F81F9: from=<dicemans82@libero.it>, size=873, nrcpt=1 (queue active)
Dec  9 14:29:12 mailserver postfix/smtpd[3958]: connect from mailserver.ilquotidianoweb.it[127.0.0.1]
Dec  9 14:29:12 mailserver postfix/smtpd[3958]: D39BF37F8274: client=mailserver.ilquotidianoweb.it[127.0.0.1]
Dec  9 14:29:12 mailserver postfix/cleanup[3954]: D39BF37F8274: message-id=<18089172.1743461291901318921.JavaMail.root@wmail10.libero.it>
Dec  9 14:29:12 mailserver postfix/qmgr[3562]: D39BF37F8274: from=<dicemans82@libero.it>, size=1377, nrcpt=1 (queue active)
Dec  9 14:29:12 mailserver postfix/smtpd[3958]: disconnect from mailserver.ilquotidianoweb.it[127.0.0.1]
Dec  9 14:29:12 mailserver amavis[2609]: (02609-05) Passed CLEAN, LOCAL [212.52.84.104] [212.52.84.104] <dicemans82@libero.it> -> <info@wizone.it>, Message-ID: <18089172.1743461291901318921.JavaMail.root@wmail10.libero.it>, mail_id: 6yxh81fCSSAp, Hits: -8.45, size: 873, queued_as: D39BF37F8274, 458 ms
Dec  9 14:29:12 mailserver postfix/smtp[3955]: 5689137F81F9: to=<info@wizone.it>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.58, delays=0.11/0/0/0.46, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=02609-05, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as D39BF37F8274)
Dec  9 14:29:12 mailserver postfix/qmgr[3562]: 5689137F81F9: removed
Dec  9 14:29:12 mailserver postfix/pipe[3959]: D39BF37F8274: to=<info@wizone.it>, relay=dovecot, delay=0.02, delays=0/0.01/0/0.01, dsn=2.0.0, status=sent (delivered via dovecot service)
Dec  9 14:29:12 mailserver postfix/qmgr[3562]: D39BF37F8274: removed

why the server has this behavior? You can avoid this?