Topic: Awstats in iRedMail-0.7.0-beta1

I just installed Iredmail on FreeBSD 8 machine and I found out that Awstats is not working on iot getting the below error aftre loggin in

Error: Couldn't open config file "awstats.mail.conf" nor "awstats.conf" after searching in path "/usr/local/www/awstats/cgi-bin,/etc/awstats,/usr/local/etc/awstats,/etc,/etc/opt/awstats": No such file or directory

- Did you use the correct URL ?
Example: http://localhost/awstats/awstats.pl?config=mysite
- Did you create your config file 'awstats.mail.conf' ?
If not, you can run "awstats_configure.pl" from command line, or create it manually.

Check config file, permissions and AWStats documentation (in 'docs' directory).

Any solution for this ?


Re: Awstats in iRedMail-0.7.0-beta1

Bug in 0.7.0-beta1. Fixed moment ago. Thanks very much for your feedback.

It should be /usr/local/www/awstats/cgi-bin/awstats.web.conf and /usr/local/www/awstats/cgi-bin/awstats.smtp.conf, but it was incorrectly configured as /etc/awstats/awstats.web.conf and /etc/awstats/awstats.smtp.conf.



Re: Awstats in iRedMail-0.7.0-beta1

Where do I need to change on my server?so that it should start working?


Re: Awstats in iRedMail-0.7.0-beta1

Awstats ships a sample config file: /usr/local/www/awstats/cgi-bin/awstats.model.conf. You can copy it to awstats.smtp.conf, edit related settings to make it work. Reference:
http://iredmail.googlecode.com/hg/iRedM … awstats.sh