1

Topic: warning and error installations in iRedMail-0.6.1

hi all, I am trying to install iRedMail-0.6.1. proceed with sh get_all.sh and all good.  then start bash iRedMail.sh all steps go well until the point where it starts downloading Package. My log says:

After this operation, 0B of additional disk space will be used.
Setting up postfix-policyd (1.82-2) ...
dbconfig-common: writing config to /etc/dbconfig-common/postfix-policyd.conf
*** WARNING: ucf was run from a maintainer script that uses debconf, but
             the script did not pass --debconf-ok to ucf. The maintainer
             script should be fixed to not stop debconf before calling ucf,
             and pass it this parameter. For now, ucf will revert to using
             old-style, non-debconf prompting. Ugh!

             Please inform the package maintainer about this problem.
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO).
unable to connect to mysql server.
error encountered creating user:
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
dbconfig-common: postfix-policyd configure: aborted.
dbconfig-common: flushing administrative password
dpkg: error processing postfix-policyd (--configure):
subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
postfix-policyd
E: Sub-process /usr/bin/dpkg returned an error code (1)
< ERROR > Installation failed, please check the terminal output


I'm no expert on the subject but is in fact to walk. appreciate any help. Thanks to all

2

Re: warning and error installations in iRedMail-0.6.1

solution.

my problem was that I had not run the command

sudo apt-get install debian-archive-keyring

which generated the database  postfix-policyd

thanks to everyone and I hope excuse me

3

Re: warning and error installations in iRedMail-0.6.1

On Ubuntu 10.04 LTS I tried the solution, and I then tried removing all postfix packages and reinstalling--still get the same errors.

I seem to be in a "chicken and egg" situation trying to correct errors.  I suspect part of my problem is that I do not have a freshly installed server, but I have tried to remove all appropriate packages and still get the same errors.  Is there any hope for my not-so-fresh server?  I have no configurations that are sacred other than my personal user account--the main purpose for my host is to be a web and mail server.

All suggestions welcome!

Thanks.

-Tom

4

Re: warning and error installations in iRedMail-0.6.1

You can try this script to remove iRedMail:
http://iredmail.googlecode.com/hg/extra … redmail.sh

WARNING: It will remove binary packages, system accounts without confirm from you.

5

Re: warning and error installations in iRedMail-0.6.1

try this script to remove iRedMail: http://iredmail.googlecode.com/hg/extra … redmail.sh

Thank you--I'll try that.

-Tom