1 (edited by Cédric 2010-10-13 16:42:07)

Topic: [SOLVED]Enable.Throttling/Debian.Ubuntu

Hi everyone,

I'm trying to enable throttling with the help of the wiki but i can't make it work.  ( i'm on 0.6.0-rc1 )
When i try to start / restart /etc/init.d/postfix-policyd_sender_throttle, it doesn't start ( and i've got nothing in the log file ) and with a netstat -ntlp | grep -i 1003 i only see the 10031 port not the 10032.

I'm wondering if it can create PIDFILE is their a way to create it manualy ?
Shoud I upgrade to 0.6.1 first ?

i've set SENDERTHROTTLE=1 SENDER_THROTTLE_SASL=1 SENDER_THROTTLE_HOST=0 RECIPIENTTHROTTLE=1 in the postfix-policyd_sender_throttle.conf

Heres is my /etc/init.d/postfix-policyd_sender_throttle

#! /bin/sh
### BEGIN INIT INFO
# Provides:          postfix-policyd_sender_throttle
# Required-Start:    $remote_fs $syslog
# Required-Stop:     $remote_fs $syslog
# Default-Start:     2 3 4 5
# Default-Stop:      0 1 6
### END INIT INFO

PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
DAEMON=/usr/sbin/postfix-policyd
CONFIG=/etc/postfix-policyd_sender_throttle.conf
NAME=postfix-policyd_sender_throttle
DESC="Postfix greylisting policy daemon"

test -x $DAEMON || exit 0

# Include policyd defaults if available
#if [ -f /etc/default/postfix-policyd ] ; then
#       . /etc/default/postfix-policyd
#fi

set -e

PIDFILE=/var/run/policyd_sender_throttle.pid

case "$1" in
  start)
        echo -n "Starting $DESC: "
        start-stop-daemon --start --quiet --background --pidfile $PIDFILE --exec $DAEMON -- -c $DAEMON_CONFIG
        echo "$NAME."
        ;;
  stop)
        echo -n "Stopping $DESC: "
        start-stop-daemon --stop --quiet --pidfile $PIDFILE --exec $DAEMON
        echo "$NAME."
        ;;
  reload|force-reload)
        echo -n "Reloading $DESC configuration: "
        start-stop-daemon --stop --signal 1 --quiet --pidfile $PIDFILE --exec $DAEMON
        echo "$NAME."
        ;;
  restart)
        echo -n "Restarting $DESC: "
        start-stop-daemon --stop --quiet --pidfile $PIDFILE --exec $DAEMON
        sleep 1
        start-stop-daemon --start --quiet --background --pidfile $PIDFILE --exec $DAEMON -- -c $DAEMON_CONFIG
        echo "$NAME."
        ;;
  *)
        N=/etc/init.d/$NAME
        echo "Usage: $N {start|stop|restart|reload|force-reload}" >&2
        exit 1

esac

exit 0

Thanks for all your advices.

2

Re: [SOLVED]Enable.Throttling/Debian.Ubuntu

Any error message after start failed? Policyd will log error message in /var/log/maillog.

3

Re: [SOLVED]Enable.Throttling/Debian.Ubuntu

No error at all

when i type :

/etc/init.d/postfix-policyd_sender_throttle restart

i got :

Restarting Postfix greylisting policy daemon: 

And it stop.

4

Re: [SOLVED]Enable.Throttling/Debian.Ubuntu

Try below commands to get debug message in /var/log/maillog:

# /usr/sbin/postfix-policyd -c /etc/postfix-policyd_sender_throttle.conf

If no error message, try to increase 'DEBUG' value in /etc/postfix-policyd_sender_throttle.conf and try again.

5

Re: [SOLVED]Enable.Throttling/Debian.Ubuntu

Hmm....

With this command : /usr/sbin/postfix-policyd -c /etc/postfix-policyd_sender_throttle.conf

It works >_<

But if i restart ( /etc/init.d/postfix-policyd_sender_throttle restart) , it don't anymore.

6

Re: [SOLVED]Enable.Throttling/Debian.Ubuntu

I'm starting to think that i have some issues in my /etc/init.d/postfix-policyd_sender_throttle file (because with command line it works )
But i can't find where...

7

Re: [SOLVED]Enable.Throttling/Debian.Ubuntu

Cédric wrote:

But if i restart ( /etc/init.d/postfix-policyd_sender_throttle restart) , it don't anymore.

Try:

# bash -xv /etc/init.d/postfix-policyd_sender_throttle start

And post output of terminal here.

8

Re: [SOLVED]Enable.Throttling/Debian.Ubuntu

#! /bin/sh
### BEGIN INIT INFO
# Provides:          postfix-policyd_sender_throttle
# Required-Start:    $remote_fs $syslog
# Required-Stop:     $remote_fs $syslog
# Default-Start:     2 3 4 5
# Default-Stop:      0 1 6
### END INIT INFO

PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
+ PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
DAEMON=/usr/sbin/postfix-policyd
+ DAEMON=/usr/sbin/postfix-policyd
CONFIG=/etc/postfix-policyd_sender_throttle.conf
+ CONFIG=/etc/postfix-policyd_sender_throttle.conf
NAME=postfix-policyd
+ NAME=postfix-policyd
DESC="Postfix greylisting policy daemon"
+ DESC='Postfix greylisting policy daemon'

test -x $DAEMON || exit 0
+ test -x /usr/sbin/postfix-policyd

# Include policyd defaults if available
#if [ -f /etc/default/postfix-policyd ] ; then
#       . /etc/default/postfix-policyd
#fi

set -e
+ set -e

PIDFILE="/var/run/policyd_sender_throttle.pid"
+ PIDFILE=/var/run/policyd_sender_throttle.pid

case "$1" in
  start)
        echo -n "Starting $DESC: "
        start-stop-daemon --start --quiet --background --pidfile $PIDFILE --exec $DAEMON -- -c $DAEMON_CONFIG
        echo "$NAME."
        ;;
  stop)
        echo -n "Stopping $DESC: "
        start-stop-daemon --stop --quiet --pidfile $PIDFILE --exec $DAEMON
        echo "$NAME."
        ;;
  reload|force-reload)
        echo -n "Reloading $DESC configuration: "
        start-stop-daemon --stop --signal 1 --quiet --pidfile $PIDFILE --exec $DAEMON
        echo "$NAME."
        ;;
  restart)
        echo -n "Restarting $DESC: "
        start-stop-daemon --stop --quiet --pidfile $PIDFILE --exec $DAEMON
        sleep 1
        start-stop-daemon --start --quiet --background --pidfile $PIDFILE --exec $DAEMON -- -c $DAEMON_CONFIG
        echo "$NAME."
        ;;
  *)
        N=/etc/init.d/$NAME
        echo "Usage: $N {start|stop|restart|reload|force-reload}" >&2
        exit 1
        ;;
esac
+ case "$1" in
+ echo -n 'Starting Postfix greylisting policy daemon: '
Starting Postfix greylisting policy daemon: + start-stop-daemon --start --quiet --background --pidfile /var/run/policyd_sender_throttle.pid --exec /usr/sbin/postfix-policyd -- -c
+ echo postfix-policyd.
postfix-policyd.

exit 0
+ exit 0

Here are the resulsts

9

Re: [SOLVED]Enable.Throttling/Debian.Ubuntu

In /etc/init.d/postfix-policyd_sender_throttle:

start-stop-daemon --start --quiet --background --pidfile $PIDFILE --exec $DAEMON -- -c $DAEMON_CONFIG

But we don't have variable "DAEMON_CONFIG" after we comment out below lines:

# Include policyd defaults if available
#if [ -f /etc/default/postfix-policyd ] ; then
#       . /etc/default/postfix-policyd
#fi

So we should change 'DAEMON_CONFIG' to 'CONFIG'.

Could you please help test it?

10

Re: [SOLVED]Enable.Throttling/Debian.Ubuntu

Works perfectly !

Thanks big_smile