1

Topic: changing roundcube's alias to "/" kills iredadmin

I have everything working the way it should and my last tweak is make roundcube the default page.  I want http://mail.mydomain.com to open roundcube.

So, I changed the alias from "/mail" to "/" in roundcube.conf  (I get a couple of warnings, but they don't appear to be the problem) and https://mail.mydomain.com/iredadmin  quits working.

I've gone through all of the apache conf files and I don't see any reason changing the roundcube alias is causing the problem.

any ideas?  Is there a better way?

2

Re: changing roundcube's alias to "/" kills iredadmin

How about redirect / to /mail in index.html file instead of chaning Apache config file? like this:

<html>
    <head>
        <meta HTTP-EQUIV="REFRESH" content="0; url=http://your_server.com/mail/">
    </head>
</html>

3

Re: changing roundcube's alias to "/" kills iredadmin

I realize this is an option.  It always feels wrong to do such things. No, it is wrong.  It's a waste of CPU, bandwidth and the enduser's time.  For no good reason.   That being said, I've already done this as a temporary workaround.

What's the correct solution?

4

Re: changing roundcube's alias to "/" kills iredadmin

Can you show us what you did to change "/" to "/mail"? So that i can test it with your settings.

5

Re: changing roundcube's alias to "/" kills iredadmin

ZhangHuangbin wrote:

Can you show us what you did to change "/" to "/mail"? So that i can test it with your settings.

Sure, but it's the other way around.  I changed "/mail" to "/".  Also, this change does not affect phpmyadmin, phpldapadmin and roundcube does work.  iredadmin no longer functions.

in /etc/httpd/conf.d   I changed roundcubemail.conf from...  (notice the uncommented alias)

# Note: Please refer to /etc/httpd/conf.d/ssl.conf for SSL/TLS setting.
Alias /mail "/var/www/roundcubemail/"
#Alias /webmail "/var/www/roundcubemail/"
#Alias /roundcube "/var/www/roundcubemail/"
<Directory "/var/www/roundcubemail/">
    Options -Indexes
</Directory>

TO

# Note: Please refer to /etc/httpd/conf.d/ssl.conf for SSL/TLS setting.
Alias / "/var/www/roundcubemail/"
#Alias /webmail "/var/www/roundcubemail/"
#Alias /roundcube "/var/www/roundcubemail/"
<Directory "/var/www/roundcubemail/">
    Options -Indexes
</Directory>

6

Re: changing roundcube's alias to "/" kills iredadmin

You can simply change "DocumentRoot" to /var/www/roundcubemail in /etc/httpd/conf/httpd.conf, works for me here.
http/https + (/, /mail) are Roundcube webmail, https + (phpMyAdmin, phpLDAPadmin, iRedAdmin) work well.

7

Re: changing roundcube's alias to "/" kills iredadmin

delete /var/www, create symlink to rouncubemail install folder as /var/www. or move rouncube directly in /var/www