1

Topic: Subject changing...

Hi All,

Some of my mails are changing the Subject when sent to internal users. If I am getting a Subject changed, I know that it will be going to client also. I have checked spamassassin config/amavis config/postfix config/postfix-policy config.

My subject changes to [***UNCHECKED*** Re: Feedback on main section XXXXXXXXXXXXXXXXX]. From where is this UNCHECKED coming...?

Thanks

2

Re: Subject changing...

That's strange.

Amavisd will invoke SpamAssassin for anti-spam, and prepend "SPAM" in mail subject by default. But not "UNCHECKED".
Maybe it's amavisd setting, but i don't know yet. Or do you have customized spamassassin rule?

3

Re: Subject changing...

From Amavisd doc, i found this in amavisd.conf-sample:

$undecipherable_subject_tag = '***UNCHECKED*** ';  # undef disables it

To disable it, you can change it to:

$undecipherable_subject_tag = undef;

4

Re: Subject changing...

My system is having Ubuntu.
Linux mailadmin 2.6.28-19-server #65-Ubuntu SMP Thu Sep 16 15:15:59 UTC 2010 i686 GNU/Linux
I am not able to find a file with name amavisd.conf-sample.
My server is having /etc/amavisd/conf.d/{-----}. None of the file is having a variable $undecipherable_subject_tag.
Where can I find out amavisd.conf-sample in ubuntu.

Tx

5

Re: Subject changing...

You can add this setting in /etc/amavisd/conf.d/50-user