1 (edited by robertut 2010-10-20 03:37:47)

Topic: (solved - bug) Deny access to https://server_address/postfixadmin

Hello all!

I installed successfully iRedMail on my Ubuntu LTS 10.04.1 - all works fine, thanks.
Now I'd fine-tune and customize security settings - for example, I wish to enable access to these pages only from my local subnet:
https://server_address/postfixadmin
https://server_address/phpmyadmin
https://server_address/awstats/awstats.pl
I successfully enabled in Apache config files (/etc/apache2/conf.d/postfixadmin.conf, /etc/apache2/conf.d/phpmyadmin.conf, /etc/apache2/conf.d/awstats.conf) the following:
    order deny,allow
    deny from all
    allow from 192.168.1.
Unfortunately this only works for phpmyadmin and awstats. It doesn't apply for postfixadmin - /etc/apache2/conf.d/postfixadmin.conf has no other options.

Please help me on this... any idea where to search for the problem?

Regards
R

2

Re: (solved - bug) Deny access to https://server_address/postfixadmin

What do you mean "/etc/apache2/conf.d/postfixadmin.conf has no other options"?
You can simply add above options in postfixadmin.conf, and it should work as expected.

Also, take a look at /etc/apache2/sites-available/default-ssl.

3 (edited by robertut 2010-10-04 20:59:39)

Re: (solved - bug) Deny access to https://server_address/postfixadmin

All there is in /etc/apache2/conf.d/postfixadmin.conf after fresh install of iRedMail on Ubuntu LTS 10.04.1 is:

    Options -Indexes

I added the lines from my first post - IT DOESN'T work. It works in case of phpmyadmin and awstats, but NOT postfixadmin.

In /etc/apache2/sites-available/default-ssl all seems fine I think, it only references /var/www and /usr/lib/cgi-bin - phpmyadmin and postfixadmin are not mentioned here, so it should affect both in same manner.

4

Re: (solved - bug) Deny access to https://server_address/postfixadmin

Any help please?

5

Re: (solved - bug) Deny access to https://server_address/postfixadmin

try making your postfixadmin.conf file look like this... obviously change to the appropriate directories etc.

Alias /postfixadmin "/var/www/postfixadmin/"
<Directory "/var/www/postfixadmin/">
    order deny,allow
    deny from all
    allow from 192.168.1.
    Options -Indexes
</Directory>

6

Re: (solved - bug) Deny access to https://server_address/postfixadmin

Thanks, but meanwhile I discovered that by default the postfixadmin.conf file referenced to the wrong directory:
<Directory "/usr/share/apache2/postfixadmin-2.3/"> - this is wrong
<Directory "/usr/share/apache2/postfixadmin/"> - this is good now - it references to the symlink the installer generates.
phpmyadmin worked as expected because the reference of Directory was correct.

Please fix this bug in the next version of iRedMail installer.