1 (edited by hata_ph 2010-09-21 10:00:51)

Topic: Update php for iRedMail

Today I trying to update my iRedOS server and encounter below message...
I do notice there is another thread about update php, is this the same issue?

http://www.iredmail.org/forum/topic1244 … hp-52.html

I am currently using php 5.1.6

[root@mail ~]# php --version
PHP 5.1.6 (cli) (built: Mar 31 2010 02:44:37)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies
    with eAccelerator v0.9.5.2, Copyright (c) 2004-2006 eAccelerator, by eAccelerator

[root@mail ~]# yum check-update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* addons: centos.maulvi.net
* base: centos.maulvi.net
* extras: centos.maulvi.net
* updates: centos.maulvi.net

apr-util.i386                                                                           1.2.7-11.el5_5.1                                                                 updates
device-mapper-multipath.i386                                                            0.4.7-34.el5_5.5                                                                 updates
kpartx.i386                                                                             0.4.7-34.el5_5.5                                                                 updates
php.i386                                                                                5.2.10-1.el5.centos                                                              iRedMail
php-cli.i386                                                                            5.2.10-1.el5.centos                                                              iRedMail
php-common.i386                                                                         5.2.10-1.el5.centos                                                              iRedMail
php-devel.i386                                                                          5.2.10-1.el5.centos                                                              iRedMail
php-gd.i386                                                                             5.2.10-1.el5.centos                                                              iRedMail
php-imap.i386                                                                           5.2.10-1.el5.centos                                                              iRedMail
php-ldap.i386                                                                           5.2.10-1.el5.centos                                                              iRedMail
php-mbstring.i386                                                                       5.2.10-1.el5.centos                                                              iRedMail
php-mcrypt.i386                                                                         5.2.9-2.el5.centos.3                                                             iRedMail
php-mysql.i386                                                                          5.2.10-1.el5.centos                                                              iRedMail
php-pdo.i386                                                                            5.2.10-1.el5.centos                                                              iRedMail
php-xml.i386                                                                            5.2.10-1.el5.centos                                                              iRedMail
[root@mail ~]# yum update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* addons: centos.maulvi.net
* base: centos.maulvi.net
* extras: centos.maulvi.net
* updates: centos.maulvi.net
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package apr-util.i386 0:1.2.7-11.el5_5.1 set to be updated
---> Package device-mapper-multipath.i386 0:0.4.7-34.el5_5.5 set to be updated
---> Package kpartx.i386 0:0.4.7-34.el5_5.5 set to be updated
--> Processing Dependency: php = 5.1.6 for package: php-eaccelerator
---> Package php.i386 0:5.2.10-1.el5.centos set to be updated
---> Package php-cli.i386 0:5.2.10-1.el5.centos set to be updated
---> Package php-common.i386 0:5.2.10-1.el5.centos set to be updated
---> Package php-devel.i386 0:5.2.10-1.el5.centos set to be updated
---> Package php-gd.i386 0:5.2.10-1.el5.centos set to be updated
---> Package php-imap.i386 0:5.2.10-1.el5.centos set to be updated
---> Package php-ldap.i386 0:5.2.10-1.el5.centos set to be updated
---> Package php-mbstring.i386 0:5.2.10-1.el5.centos set to be updated
---> Package php-mcrypt.i386 0:5.2.9-2.el5.centos.3 set to be updated
---> Package php-mysql.i386 0:5.2.10-1.el5.centos set to be updated
---> Package php-pdo.i386 0:5.2.10-1.el5.centos set to be updated
---> Package php-xml.i386 0:5.2.10-1.el5.centos set to be updated
--> Finished Dependency Resolution
php-eaccelerator-5.1.6_0.9.5.2-4.el5.rf.i386 from installed has depsolving problems
  --> Missing Dependency: php = 5.1.6 is needed by package php-eaccelerator-5.1.6_0.9.5.2-4.el5.rf.i386 (installed)
Error: Missing Dependency: php = 5.1.6 is needed by package php-eaccelerator-5.1.6_0.9.5.2-4.el5.rf.i386 (installed)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

2

Re: Update php for iRedMail

php-eaccelerator is not available in yum repository, you have to either remove it or stay in php-5.1.x.

3

Re: Update php for iRedMail

Is php-eaccelerator is a must for iRedMail?

4

Re: Update php for iRedMail

It's an optional component, used to speed up PHP applications.

5

Re: Update php for iRedMail

Will future version iRedMail come with php-eaccelerator?

6

Re: Update php for iRedMail

If there's no php-eaccelerator available in CentOS Testing repo, we won't provide it.