1

Topic: Spamassassin Upgrade on CentOS 5.5

Greetings,

I've run into a few bugs in Spamassassin that is causing incorrect Spam flags in my email.

CentOS 5.5 ships with Spamassassin 3.2.5, however there are some key fixes in 3.3.x that I would like to use, namely these two:

http://wiki.apache.org/spamassassin/Rul … _OPENWHOIS
http://wiki.apache.org/spamassassin/Rul … _PAST_20XX

Is there a recommended safe way of upgrading Spamassassin to 3.3.x without killing off my mail server?

Thanks!

2

Re: Spamassassin Upgrade on CentOS 5.5

I'am interesting in it too. Can anybody answer?

3

Re: Spamassassin Upgrade on CentOS 5.5

I have successfully upgraded my CentOS spamassassin.

First, Spamassassin 3.3.1 requires perl-IO-Socket-INET6:

yum install perl-IO-Socket-INET6

Then, install the el5 RPM:

rpm -Uvh http://wtogami.fedorapeople.org/temp/spamassassin/el5/spamassassin-3.3.1-2.el5.x86_64.rpm

Good Luck!