1

Topic: iRedMail 0.5.0-RC1 Debian 5.0.x new user issues

Hi,

Having an issue after following the tutorial on howtoforge:


http://www.howtoforge.com/iredmail-mail … .1#comment

(I'm using OpenLDAP)

I noticed that I can't send e-mails from a newly created account:

Jun 28 01:39:29 r2d2 roundcube: [28-Jun-2009 01:39:29 -0500] SMTP Error: SMTP error: Failed to add recipient 'SOMEUSERATSOMEDOMAIN@REMOTE.COM' in /usr/share/apache2/roundcubemail-0.2.1/program/steps/mail/func.inc on line 1296 (POST /roundcube/?_task=mail&_action=send)

If I try to send an e-mail to this user from a remote domain, I see the following in the mail logs:

Jun 28 01:39:29 r2d2 postfix/smtpd[9115]: NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 550 5.1.0 <newuser@my.domain.com>: Sender address rejected: User unknown in local recipient table; from=<newuser@my.domain.com> to=<SOMEUSERATSOMEDOMAIN@REMOTE.COM> proto=ESMTP helo=<rmy.domain.com>

I can login to the webmail client with the newly created user fine, but mail cannot be sent or recivied due to the errors above.

Looking back at my create script, it looks like it had a couple of errors:

r2d2:~/iRedMail-0.5.0-rc1/tools# ./create_mail_user_OpenLDAP.sh my.domain.com newuser
adding new entry "ou=Users,domainName=my.domain.com,o=domains,dc=my,dc=domain,dc=com"
ldap_add: Already exists (68)


adding new entry "ou=Groups,domainName=my.domain.com,o=domains,dc=my,dc=domain,dc=com"
ldap_add: Already exists (68)

adding new entry "ou=Aliases,domainName=my.domain.com,o=domains,dc=my,dc=domain,dc=com"
ldap_add: Already exists (68)

adding new entry "mail=newuser@my.domain.com,ou=Users,domainName=my.domain.com,o=domains,dc=my,dc=domain,dc=com"

* There's no error on the last one.

My LDAP settings look like:

# ------------------------------------------------------------------
# -------------------------- LDAP Setting --------------------------
# ------------------------------------------------------------------
LDAP_SUFFIX="dc=my,dc=domain,dc=com"

# Setting 'BASE_DN'.
BASE_DN="o=domains,${LDAP_SUFFIX}"

# Setting 'DOMAIN_NAME' and DOMAIN_DN':
#     * DOMAIN will be used in mail address: ${USERNAME}@${DOMAIN}
#    * DOMAIN_DN will be used in LDAP dn.
DOMAIN_NAME="$1"
DOMAIN_DN="domainName=${DOMAIN_NAME}"
OU_USER_DN="ou=Users"

# ---------- rootdn of LDAP Server ----------
# Setting rootdn of LDAP.
BINDDN="cn=Manager,${LDAP_SUFFIX}"

# Setting rootpw of LDAP.
BINDPW='areallyuberelitepassword'

Any ideas or thoughts?

2

Re: iRedMail 0.5.0-RC1 Debian 5.0.x new user issues

Could you please export the LDIF data of this new user?

3 (edited by knobdy 2009-06-29 01:14:15)

Re: iRedMail 0.5.0-RC1 Debian 5.0.x new user issues

Hi,

Exported LDIF data attached (modified so that my real domain = my.real.domain).

4

Re: iRedMail 0.5.0-RC1 Debian 5.0.x new user issues

It seems all are correct in LDIF data.

Could you please try to debug ldap query? Steps:

- Increase loglevel in /etc/ldap/slapd.conf:

loglevel    256

- Restart openldap, and then monitor /var/log/openldap.log.

You can post logs in /var/log/openldap.log.

5

Re: iRedMail 0.5.0-RC1 Debian 5.0.x new user issues

i have the same problems with my first domain. i created a new domain after installations and all works fine for them..